How does Bulk Add Hosted Assets work?

Did you fill in the base URL within the bookmark preference of Forklift for your domain? Also the path?

I don’t get the same result as you when I copy the url to the clipboard. I think Forklift like any other app needs those parameters to create the correct URL. It was like that with Yummy as well.

Its also in the user documentation, scroll down to the topic Copy URL!

Hello and thanks for quick response.
Sorry, when reading the documentation I found out of it. It now gives me the correct url when pasting into blocs. But blocs now just showing the sync symbol. It is either very slow or not working.

Mine syncs in about a second, even with a hundred links. I wonder if you have network issues. Do you have any blocks in place on the server like hotlink protection?

I don’t know. With forklift and filezilla before that, I upload and download the whole project in seconds. So it must be something in blocs or combination of blocs and my host server.

If you have hotlink protection enabled on the server it would stop other sites linking directly to images on your site and showing them on their pages. In theory it might also block Blocs as well.

In that case I have to go back to my web hotel provider, because that is above my knowledge.
I am just a writer who wants to build a website or two and a blog.

It’s worth checking. Sometimes people do this to stop others effectively stealing bandwidth. If your URLs are correct and your server is responding normally the images should appear in a second of two.

An afterthought but are you missing the www?

Solvberg! If it’s any consolation, I’m having the same problem trying to upload “hosted assets”. I also get the “sync symbol” which goes on for eternity and I end up having to shut down blocs. I also had the same problem with images continually disappearing after saving and reopening a project. Then having had to relink for the same thing only to happen again and again.
See: https://forum.blocsapp.com/t/importing-hosted-assests/10407/9 I was initially using Cyberduck and tried Filezilla (but like you, couldn’t work out how to get http links) I’m ready to try Forklift but before that I would have to change some of my Japanese file names as I am assuming from what has been said here, that Japanese characters wouldn’t be accepted.
So, I’m also following this thread eagerly to see if this problem can be solved. I currently have my assets hosted locally (working on a new project), but if I can, I would like to host them externally.
Thanks in advance for any good solution.
Sabina

Sorry I had some problems registering and get a new domain up and go. I have added www to the url link in Forklift as @Flashman suggested , but still the same result, a churning sync icon. I tried with \r instead of \n but to no avail. Forklift seems to be a very capable app, not only for ftp-ing. I haven’t had time to talk to the provider yet. On the other side, I don’t have gigabytes of images in my web design, and I do reduce all images with export for web function in Pixelmator Pro. The design are usually small, is less than 20 MB and uploads in seconds. In that sense it is not a big deal, but of course if one have GBs of images, then it certainly makes sense. So they should look into to make it more robust, one way or other

I think there is something wrong with your particular setup and it might be a networking issue. Having produced a large number of websites with remote hosting to various servers it’s hard to see what Blocs could do to make this more robust. It is simply connecting to an image on a server using a normal weblink just like other apps do.

If you take one of those copied urls from Forklift and simply paste it into a browser address window does the image appear normally? BTW The img folder is normally reserved for images exported from Blocs that were added locally. Try calling that folder images or something else.

Maybe @Norm has some idea of what could be wrong here.

Have you done all the things explained in the forklift user-manual “copy URL” section?
For me, that works great now, no more renaming urls, for bulk import!
And even adding a few more images, to a folder at website is easy now. I just copied them in.
Then I go to the group in asset-manager, where I wanted to add the new pictures and copied the links of all the images(from forklift -copy URLs) of matching hosted folder(which contained the new ones), and asset-manager refreshes with the new ones. I was really worried, that this works. But it does work.

Hello again,
I have tried what you say. I can import images one by one to blocs. When copying one url and paste it into the browser, the image comes up in no time. Trying to import 2 images does not work. Now, I am on a mobile internet router, but that should not be a problem as I am up- and downloading scores of GB pr. week. I made a new folder and uploaded new images and tried to import 3 images, but to no avail. I could have something with the mobile router to do, but why can I import 1 image but not two?

Hi,
Can you give us 2 to 3 urls to your images?
With https://shannonvalemorgans.com/test/img/BrillFooter1200x415.jpg from 2 days ago, this seemed to work. I can try out, what’s happening to me, with bulk import!

Cheers, Michael

Edit: tried out with above, and two other images available on your website, seemed no problem.
I have had problems before with images not importing, because of improper naming(they imported in a way, but showed no missing-preview), but never had this sync symbol appearing…

You can try these.



Perhaps I do something not quite right in forklift. Can you take some snaps of yours, blurred of course…

@Solvberg I think there may be something wrong with your source files and the way they have been saved. When uploading files to the forum it changes the names, so I renamed them simply as horse1, horse2 and horse3. I noticed that your files were appearing as jpeg, rather than jpg, but I am pretty sure asset manager will accommodate that.

I then put them on my server and attempted to bulk add them, which resulted in the spinning graphic you talk about and I have never seen that with my own images. How are you preparing these files?

No problem here for me. I saved 3 versions of your images as “horse_1.jpg” and the other time directly dragged them into finder(which resulted in .jpeg files), then put them in a folder on my server, copied the urls in forklift, and bulk imported them. So perhaps a server problem.
Can you deliver direct links to the files on your server?
You could even create a special folder with these images on you server, just for this purpose(and delete it afterwards)!

Hello @Flashman, I am using Pixelmator pro and export for web function. These images were imported into blocs, using them as local assets and uploaded the project to the test area. I also tried with images uploaded directly from my disk, without going via blocs, with the same result. Could it be something with Pixelmator and the way it is naming the images?

Hello again, @mensch.mueller. What do you mean with direct links? The urls I gave you were direct links. Or not? Sorry, confused.

I did as you did, I went onto the server with forklift and changed the names to Horse1-3 copied the URL and tried to bulk import, but still the sync icon came up and never left.