How to change the italic style of the Logo text & Main menu buttons?

Hi guys,

My name is Rada and I’m new to the forum. I need some help - here’s my issue:

After I upgraded Bloc to v.2.6.4, the text style for the company name next to my logo and for the menu buttons has changed and it’s now italic text.

How to change it from italic to normal?


This might be set in your general menu page settings. It’s somewhere. I don’t have the app in front of me at the moment. You are not using any system fonts?

Thank you for answering @HMM

Here is the screenshot of the Logo class. The italic is not selected but the logo text is in italic

Here’s a screenshot of the Project Settings - there is not an option for italic text

So I’m at loss…


Without actually seeing Blocs file I’m sorry I can’t help. I do see an italic character (to the right) in the Oswald selection. Is it possible that you selected an Italic font ?

You should be able to adjust these setting from the project settings test dropdown.

Logo text: text next to the image logo
Navigation Links: text for the navigation

1 Like

Hi @HMM. Oswald is not an italic font. I’ve tried everything but still no success…

Thank you anyway!

Hi @cassey1823, thank you for trying to help. Nothing works so far. I wasn’t able to change the font to normal neither from the Project Settings, nor using classes.

Before the last Bric update, the logo font was normal, not italic.

I’m on MacOS Mojave.

Thank you again!

Have you tried just choosing the logo without text. Save and close blocs. Then try adding text again?

If that does not work sometimes it’s just easier to delete the nav. Bloc save the project and start over.


Yes…what Casey suggests …that works quite often…
.or maybe Eldar or Norm have an answer…I’m curious if you you tried another font then back again. It does sound “stuck” as Casey says.

This didn’t work either :frowning:

I’ll try this later today. Thank you very much for helping me!

I’ve tried to change to another font several times but I couldn’t change it - the current Oswald stays unchanged !?? Very frustrating

Thank you for helping me @HMM!

I hope you get some “customer support” try adding a support ticket for your question. Good luck.

1 Like