Https... dienst work, I need to add .htaccess?

Hello guys and girls…

everytime I update my sites… something weird occurs, the https… doesn’t work,
Now my hoste (Argeweb the best ! by the way), helps me out every time and they add this .htaccess in my Public_html.

But…and here is my question: that shouldn’t be necessary… right?

I thought all we needed to do in Blocs is change it at the Projectsettings?
Am I mistaken???
thnx and regards
Anita

What are you putting in the project settings? I actually leave mine blank.

only the web address, and I leave the active link blank

I just wonder if the web address is correct.

well yep the address is correct

I don’t know, but it’s obviously particular to something you are doing or everybody would be reporting this. I assume you are uploading them to the correct directory. They certainly shouldn’t have to update the htaccess every time you update the site.

Schermafbeelding 2020-03-23 om 15.29.32

This is what it looks like…

That’s the wrong part. What about here?

Screenshot 2020-03-23 at 14.33.40

Shoot… ja…sorry… switched screens

Schermafbeelding 2020-03-23 om 15.39.27

is the www… that shouldn’t be included?

If I go to your website it is possible to access the insecure versions e.g http://www.anitasanders.nl or www.anitasanders.nl, plus https://anitasanders.nl

It’s no problem having the www in there but you should have the 301 redirect pointing everything to that one version.

1 Like

Thanks for checking… appreciated.

dear dear dear! @Flashman Flashman, apparantly this issue is not solved.
HOW and where do I add an .htaccess… ???
I no how html works… but I have no idea… where to put it in my blocs project
I have NO idea!

regards
Anita

I redirect everything to https:// without the www. This is done by creating a plaintext document at the root of your upload folder on the server next to your other files called .htaccess

N.B when you add the dot in front of htaccess the file becomes invisible, but this is perfectly normal and most good FTP apps have the ability to show invisible files. This is not something you add to the Blocs project. It goes on the server using your FTP client.

RewriteEngine On
RewriteCond %{HTTP_HOST} ^www\.(.*)
RewriteRule ^.*$ https://%1/$1 [R=301,L]

RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L]

This code above works for me. You should change the address in your project settings to https://anitasanders.nl

1 Like

Hi Anita,
even in het Nederlands:
Wat ik altijd doe; ik laat het ht.access bestand staan als ik de oude website verwijder en een nieuwe upload. Wat waarschijnlijk jouw probleem is; dat jij het ht.access bestand niet kunt zien. Dit moet je kunnen aanpassen in jouw ftp programma, zodat je het wel kunt zien…
Succes!!

1 Like

Ahh Matheus… dank dnak
ik gebruik Filezilla… waar kan ik dat verhipte ding vinden dan… want dat is precies wat Arge zegt. ik schijn het te overschrijven…

I changed the settings… the last time we spoke… however … indeed apparently I overwrite the . file

It’s very difficult to advise on any of this without seeing your server or at least a screenshot. This is probably something your web host could do for you if you ask them, though it would be good to learn yourself.

1 Like

It has to do with the fact that it is hidden… Matheus pointed that out to me… and now in FileZilla…I was able to find… through the serach option…
and yeppah… there it is… indeed in my domains… now to find a view option… so that I no longer overwrite it the next time. For my other site too…

wow… once you know somethiing… it is soo easy!

Thank you @Flashman… for your code… i’ve incorporated it in my access… doc in the ftp, for there the www redirect was not included.

and thank you @Mattheus. for helping me finding it!!!
Both sites are now up and running properly.