I only see the Blocs favicon 90% of the time


#1

I’ve made a 16 x 16 favicon, set it on Project Settings, but all I see when I publish is the Blocs one.

Any ideas?

www.poulson.info


#2

@Ian Hi Ian,

It’s probably a browser cache thing.
This is what I see in Safari, Firefox and Chrome.


#3

The same favicon shows in my browser as well.

I noticed that even when you clear the cache in browser, sometimes it might still take a few visits until the favicon shown properly in Safari. Not sure about other browsers.


#4

By the way, very nice website!


#5

Thanks for taking the time guys… I did clear the cache (what a pain) and you’re right. What confused me was the favicon kept changing, just inconsistent, but it seems okay now.

And thanks for the compliment… still a lot of work to, do but adding the shadows to the parallaxes was hard work till I sussed it. Still a beginner!

BTW, I tried getting the shadow to ‘reveal’ the pale grey bloc at the the bottom… I set it to parallax the same as the photos, but it won’t work. I’m sure there’s a reason…!


#6

Ian, how do you do the diagonal parallaxes, please?


#7

Oh boy, here goes…

Make the wedge shape (I used Pixelmator and made it something like 2000 pixels wide) and add the optional drop shadow. Save as a png. Now duplicate and flip so it’s the way round you want it. You now have top and bottom wedges.

Now, open the bloc that’s first in the available options can’t remember what it’s called) and insert the top wedge an an image. Fiddle till you’ve got it full width and with no top or bottom margin. Do the same for the bottom wedge.

Now insert a bloc between the two wedge blocs and add your content, then fill the background with whatever image you wish to use. Then select the wedge blocs one at a time and add the same background image.

Set all three blocs to parralax and it should work. Note that it’s always the blocs, not the rows or imgs which need the same background image and parallax set.

I hope that explains it. Basically I just fiddled till it worked. I’m no expert!!!


#8

Hi @Ian,
You exported your favicon as JPG, try do a new favicon with 32x32 and export as transparent PNG.

I think it will works better in retina and 4k monitors. :wink:


#9

Tips… there are lots of favicon generators online.
Just upload your image and it will generate a proper favicon.ico.


#10

Didn’t know favicons had gone up in size, thanks!


#11

Thanks, I’ll give it a try - I see animated favicons are possible…!


#12

Yes and in retina / 4k monitors have a big difference.


#13

Many thanks, Ian. That’s going into my spreadsheet of Blocs tips!