Images not appearing but definitely on server


#1

I’ve uploaded a new page to a site http://www.livecompanygroup.com/blog.html and the top image bloc isn’t displaying correctly. The connected image is definitely on the server. I’ve tried swopping images to other ones and they appear if they’re present on another page - that’s the way I’ve left it at the moment - but If I connect to other unique images (not on other pages but definitely in the right place with the correct name on the server) they don’t appear either.

The image of NYC on the page wasn’t showing either until I changed the file name a few times on the server by removing the .jpg suffix and then replacing it and until it suddenly appeared. That hasn’t worked with the other images I was trying.

All the images have been exported in the same way so that they’re identical sizes.

Any suggestions?


#2

Hi @sim

It sound like a browser cache thing.
Try holding shift and refresh the page.
Clear the browser cache.
Test the site with another browser.

This is how it looked when I tested it.

site


#3

Hi @Jakerlund. Thanks for all of the contributions you’ve made on the forum. I’ve learnt a lot from you.

This is one of the replacement images so I know it’s working. I just can’t figure out why the other ones wouldn’t appear.


#4

It’s working fine for me. Are you using CloudFlare, LightSpeed or anything similar? They could be very sticky in your cache.


#5

Nope. But here’s the issue on a spare host I have - so not the one the public see.

http://unbrokenenglish.com/blog1.html


#6

In this case I can see the problem.


#7

Yes, and I’ve replaced the image on the other blog page now at http://unbrokenenglish.com/blog.html and once again it’s not appearing but I can see it on the server.

Here’s the FTP folder:

  • the missing image is KOR_SEOUL_CAROUSEL_2643 and it’s there on both sides (and although you can’t see it the file size is the same).

I’ve just disabled lazy loading and reloaded the site on unbrokenenglish.com. It now appears to be working. Can anyone shed any light on why those particular images may be an issue?


#8

It looks like the class “bg-NYC-BACKGROUND” class was missing in the style.css.
But the html page had the reference to it.


#9

Now the site seems to work :slight_smile:
Did you solve it?


#10

I’ve disabled lazy loading and that seemed to solve it.


#11

I’ll experiment with re-enabling it and seeing what happens!


#12

I’ve seen that a few times when others had some problems that disable lazy loading was the solution.


#13

I’ve re-enabled it, cleared the cache and for now it still appears to be showing that image. I don’t know why the reference in the .css would be missing.


#14

The “bg-NYC-BACKGROUND” is now in the style.css.
But it seems you have a few other errors.


#15


#16

Ok, thanks will have a look through. This may partly be because I’ve just thrown those pages up onto the spare host to see if the problem was still there without loading the entire site.

I’ve just followed your link to pingdom - fantastic!