Importing hosted assests

I have set up under project settings but when I try to add “hosted assets” in the “assets manager” using the above ftp address it won’t import. Can somebody please tell me where I am going wrong please?

Thanking you in advance

PS I also see now that when they are uploaded that some of the images are also very very big which I will of course address when I get this first problem sorted out

You have that all wrong. Under project settings simply add the web url of your site e.g That part is actually irrelevant to the rest.

To add hosted assets upload the file(s) to the a subfolder within the public_html area on your server. You can call the folder what you like but I usually call it _images. The underscore at the front pushes the folder to the top so it is easy to find on the server.

Now drop your image inside that folder and depending on your FTP client you will probably have an option to right click and copy as a web url. That would give you something like

Add that same link inside the asset manager as a hosted asset and you should be fine.

Thank you for that information. I realize I have the cow by the horns. But I’m still not out of the woods yet.

I did as you said with project settings irrelevant as it may be.

Screenshot 2020-04-27 09.24.15

but when I can’t see any “subfolder within the public_html area” or any “public_html” to create a folder in.

Hey, I’m truly sorry cause I know that this has to be a piece of cake for you experts.

Thanking you once again

I’m not sure whether naming the folder was the wrong way to do it. But has the current “working site” on it so I didn’t want to replace it yet.

There is something very strange with your setup. To start with you don’t need to put anything at all in the project settings and I leave that area blank, but in your case I am really confused. The only times I see something like www2 is with some banks and even then it’s rare. Here is an example

Your domain name finishing .jp2 is clearly wrong. It’s actually .jp for Japan just like it would be for the UK or .it for Italy. If you are pointing to .jp2 it simply doesn’t exist.

Looks like your server is configured to use htdocs, rather than public_html which is more common, but that shouldn’t make any difference. It’s the other points causing the difficulty I think.

It looks like you are trying to put up a draft site alongside the original and getting confused by it all. You could either place everything inside a draft folder e.g or put the draft temporarily on a different domain, just to see how it looks.

I think @JDW may be able to help you on this. He has a lot of experience with Japanese sites.

I have been playing around with this now since yesterday without much luck. Yes, I agree “domain name finishing .jp2 is clearly wrong” I thought as much but the ftp wouldn’t take anything else. I have tried again this morning on a sleep to do as you suggested and tried but the FTP setting won’t accept that either. was allocated to us by the provider and we have been using that now for some 8 years. Last evening I sent an email off to our provider explaining what I want to achieve and asking for their help in resolving the matter. Hopefully they will get back to me sometime early morning.

Thanking you for your help. Much appreciated as I can do nothing more on building my site until this matter is resolved

www2 is wrong as well. Just www, however I would add the http so you would have

Sorry that it has been some time getting back here. I have now been messing around with this problem for some 2 weeks and am still no further advanced. I talked to the Japanese provider (not that he had much idea of what I was getting at) and he did kinda sort out a few things. ( is, indeed correct as it is up and working at this present moment. Full address is: So your is technically correct but the is residing under that tree. He advised me that I can’t have as the last slash is unacceptable on their server. I also had absolutely no success in trying to create such a folder. I tried creating a _images folder but the hosted assets wouldn’t recognize that either. I’m at a loss as to what to do next.

Can you suggest how I could create or get a different domain to use just to upload the test site?

Lastly and not least. I know most people suggest using “hosted assets” over “local assets”. However, as in my case, is there any real demerit in going the “local asset” road? Wouldn’t the images be uploaded to the site when published to the site in the end? I know that when I published our current site in RW I hosted the images on site without all this fuss.

Please can either you or somebody please advise me as to what should I do? Do I scrap “hosted assets” and go “local assets” and just stop wasting time. I haven’t wanted to proceed with my site until I got this rectified. However, I could have built it maybe 2 or 3 times over given what time I have wasted now.

Thanking you,

as the images appear on the server for the current website created in RW

Blocs hosted assets won’t even recognize those images in the asset manager
Hosted assets won’t recognize
existing site full address
existing site with hosted images

Hosting images remotely is really no different in Blocs than in RW. I used RW for a few years, so I know they are similar. I clicked on your various links for the existing site and they all gave 404 not found errors. Inside the asset manager you have to link to the exact location of the image including the http bit and the name of the image file.

To try with another domain just buy one and host it somewhere, but to answer your other point there is no reason why you cannot add images locally and export them that way. It will work just as well and it sounds like it would be much simpler for you.

Thank you for your extremely prompt reply. To settle the matter once and for all I will go with your suggestion and add the images “locally”.

Once again, a big thank you. Now I can get on with business at hand. :smiley:

Hi once again. Just over a month and have finally got the option to add a hosted image. However, there are still lots of problems.
Although I must say I did a site using local images but just about every time I saved and shut down bocs it managed to unlink the images for some reason. Yes, a real pain when up against a deadline and have to continuing relink image files. This time, I did what you suggested. Created the folder _img above public_html

and added three files.

However, when I go to try just one file to the hosted files I get this:

just a question mark

When I try to bulk upload

and that is of just 3 small files, blocs goes into a non-stop recycling and I can only shut down blocs altogether to get the spinning to stop.

What do you suggest I do now please? Is there a bug in blocs that is causing this. Especially the unlinking of images on shutdown. I continually backup my project every few minutes but that doesn’t help either. That is why I thought hosting them would solve that problem. But I can’t even bulk upload using the bloc inbuilt function.

Please can somebody help me? Or suggest what I can do next.
Thanking you