Issues with the form

I tried using the form configuration to integrate an SMTP connection, but it seems to show an error when using this option!

Captura de Pantalla 2023-08-23 a la(s) 7.49.12 p.m.

It doesn’t matter which configuration I use, whether it’s or, it doesn’t seem to connect! The curious thing is that when I use the form with the regular configuration, it works fine.

Captura de Pantalla 2023-08-23 a la(s) 7.49.24 p.m.

Even when I use the configuration to use a file with the path /smtp_xxx.php that contains the same configuration as the one I filled in the first comment, it works fine.

Captura de Pantalla 2023-08-23 a la(s) 7.49.42 p.m.

I’m not sure if anyone else is experiencing any conflicts with this new configuration. Any comments are welcome.

1 Like

Hi Nelo,

Which smtp-server are you entering in the “host” field exactly? I reckon the issue could be there.
This should be the smtp-server of your hosting provider.

Best regards,


Have you tried a different port? :thinking:

YES, I have tried changing the port but nothing. The SMTP configuration is that of the hosting, the same configuration that I am using in the file that works with smtp externally.

Today I will do other tests to see if I find any connection

Thanks for the feedback.

I’m having issues with the form as well.
Whatever SMTP host server I’m using (gmail, active24, office365) with port per host’s documentation, I’m having following error message:

Settings used are Self Hosted, Sent To/From is the same as the host domain.

I tried to create completely new form, still the same error, so either this is Bloc’s issue or something to do with the host, but it should be straight-forward…?

Do you have a live URL we can take a look at?

Try port 2525 as it will mirror 587 when blocked.

Here’s the test website:
Kontakty (

SMTP server:
port 587 (already tried 2525, no luck)

Since you’re using the Gmail server, can you try using port 465 (over SSL) ?

Here’s the full list of settings to send via the Gmail server:

Gmail SMTP server address:
Gmail SMTP name: Your full name
Gmail SMTP username: Your full Gmail address (for example
Gmail SMTP password: The password you use to log in to Gmail
Gmail SMTP port (TLS): 587
Gmail SMTP port (SSL): 465

There are also some other common (but not universal) Gmail SMTP settings you may encounter when trying to set things up. You can set these as follows if you encounter them:

SSL required: Yes
TLS required: Yes
Require authentication / Use authentication: Yes
Require secure connection / Use secure connection: Yes
1 Like

It still fails, even using port 465.

In the form_1.php there is the same:
/** SMTP Server Credentials **/
$smtp_host = ‘’;
$smtp_username = ‘’;
$smtp_password = ‘mypassword’;
$smtp_port = ‘465’;

Shouldn’t I add something here?

Thunderbird for example connects without a problem to this Gmail account.
However during it’s setup, there is pop-up windows to enable Third-party apps and services to connect to this Gmail account. Maybe that’s what I’m missing here…?