License issue

I am trying to re-install Blocs 2 back on my iMac but says I have to deactivate one of my computers first. Blocs allows 2 computers for one license of which is also installed on my MacBook Pro. Which means I only have one computer that it is installed on. This is nuts? The knowledge base for this site is unobtainable showing an Error on the site page. How am I able to re-install on my second computer if I haven’t got three computers that Blocs 2 is installed on?. I have also purchased Blocs 3 but am still having issues, so having to fall back to Blocs 2.6.5 until sorted.

Anyone having the same problem?

All fine here. You should be able to login at Cazoobi and manage your licenses.

What problems are you having with Blocs 3?

Norm had to write a force Cache Bust CSS and JS into Blocs 3 as everything that went to my server was hashed up, “of which is fixed now”. Now I have an issue with Background images and links being lost every time I open Blocs 3, even assigning special classes to each image doesn’t work. This is also obvious on export of index.html prior to uploading the site. I want to revert back to Blocs 2.6.5 until things are sorted as Blocs 3 is to unpredictable and there is a lot at stake with site construction and time constraints. This is something Norm is working on and I have every faith that will be addressed, as with previous issues.

Thats very strange, because I’ve had the exact opposite experience. I was having quite a few issues with 2.6.4 that were mainly related to custom classes, however those are now behind me thankfully with Blocs 3.

It may sound like a dumb question but I assume you are saving the project before closing and also that your images are located on the same drive. Blocs 3 itself should be run from the main applications folder.

No! it’s not a dumb question, and yes everything is located to the same folder as the Blocs file and saved before exporting. Blocs definitely has gremlins of which can differ with each person occordingly. But I have been getting issues even from the beginning with Blocs 2.0 with each update resolving them. But Blocs 3 has just exceeded itself in messing up months of hard work. I can’t even revert back to Blocs 2.6.5, as I have already migrated files to Blocs 3, denying you permission. So I’m “Buggered”. :frowning:

Didn’t you retain a copy of the Blocs 2 file when migrating? If not Time Machine should bring that back.

My experience with Blocs 2 was sometimes downright frustrating and while I was able to build some websites I seemed to spend a lot more time troubleshooting than building or creating.

Having been involved with the beta testing of Blocs 3 we definitely encountered problems, but by the time we reached the last few betas it was pretty solid and definitely more stable that 2.6.4 that was on sale at the time. It would be interesting to know more about your setup. It would probably help Norm identify any issues if you can send in a support ticket along with the project file.

Yes I did save copies, but the time machine is linked to the MacBook Pro, and have been busy building the sites on the iMac, so if I went back to Blocs 2 files they would be out of date and take weeks to update. I also tried accessing Cazoobi as I signed up yesterday and kept info safe, but it just keeps locking me out, so am no wiser with license issue with Blocs 2. I only have two computers and two licences and never assigned Blocs 2 with any other computer. I emailed Norm regarding my issues with background images of which I gather is being addressed in the next few days anyway, but he hasn’t replied as yet.

I would file a bug report complete with your Blocs 3 project file to explain the issue and raise the licensing difficulty as well. If you want to send me a project file with a couple images I can certainly test those background images and links to see if this is limited to your system or something else.

I appreciate this very much, and am greatful for your support. I think I need to go back and to square one to see if although images that are displayed in project manager are indeed true linked assets to the correct folder saved to and not a copied folder on my drive that they were imported from. If I isolate and delete all missing images and rename each one, then import back to project assets, I can re-assign all lost images save project then re open project and see for myself.

That might be a cache issue. There is a reload option, but renaming image files on the server should do the trick if you restart Blocs.

Just tried deleting background image -renaming and importing this back. Shows up great and on restart, also from exported index.html. Will try server side later, but very happy at the moment.

I’ve had similar problems in Blocs 2 and with Rapidweaver as well. Sometimes the cache just gets sticky and a change in file name is needed to force it through, though the reload should work.

How about the links that were not saving? I find it can help to hit the enter key on the keyboard at the end when adding a url in the side panel. It seems to bake in the change.

Haven’t tried the enter key wacking! Have to give that one a smash or two later. When you say reload? how is this implemented or initiated in Blocs 3?.

Go to the asset manager and right click on an image, then select refresh asset. That should check again the server or local resource.


Yes I’m familiar with the refresh, but when you said reload I was assuming there was a way Blocs reloaded from the assigned folder, and if failed left the thumbnail blank as an indication. Seems like something Blocs could implement for future updates.

There is nothing to stop you bulk loading assets from the original source to see if that fixes your issues. You can delete everything from the asset manager and reimport all images. Just don’t save the project unless you are sure the change has worked.

I have tried that one. I deleted images from project assets - saved then opened again and yup!! there all back again. It only deletes if you have also deleted the image from the folder the image came from aswell, so it’s pretty useless really.

Sorry you are still having troubles. Do you work directly from Dropbox?

Norm!!! where did Flashman go?? No to your question buddy. :slight_smile: and yes still got that Blocing headache.

1 Like

I’m back in the office early tomorrow so will get to the bottom of this once and far all! I have your ticket so I’ll follow up via that.