Link in menus doesn't work uploaded to server

In the menus I somewhere link to blocs according to this article.
After some problems in the beginning it worked just fine when I previewed in browser.
But when I uploaded to server those links don’t work.
Anyone who has a clue? Thanks!

Are your exporting with Clean URLS?

Yes, I am.

The Clean URL basically removes the .html at the end of the page URL. Just remove this from the URL and it should work fine.

Thanks! I unchecked the box “Clean Page URL´s” in the export settings. It was the same result though. Those links not working.

Your url would help us take a look.


Works for me. Try clearing the cache in your browser.

Very strange. I have tried that. And tested different browsers, computers. Also tested on a windows computer and on an iPad. And it is always the same result. Those links that I have linked to a bloc don’t work.

There is a typo in you menu for menu item “Om” it is currently:

but should be: (lower case ‘m’)

If you edit that it works for me and goes to the section

Great! It worked. Thank you very much!

1 Like