Menu Hypenates - classes don't seem to fix


#1

Again, I’m new to this, so be gentle.

My navigation menu seems-to-hyphenate-words when there should just be a single space. I have tried renaming the pages with no success. I have a ‘class’ for my header menu, but I can’t find any option in it to correct the problem.


#2

The page name, shouldn’t have spaces in it, the title (what appears in your menus can). This may seem confusing but what you want to do is select the menu manager. Select the little edit button to the right of the page name. Then change the title to be without spaces.


#3

Okay…but when I do that, I get both the new UNHYPHENATED title “Another Page” appearing in my menu, but the OLD HYPHENATED ONE is still there (“Another-Page.”)

So the menu says: Another Page Another-Page.

I don’t need the same link in the menu twice. How do I get the old one to vanish?


#4

Now did you edit the existing page or hit the + on the menu manager? When I did it I selected the little bars to the right of the page. Then I edited the title, left the target alone.

I’ve found the menu manager to act a bit squirrelly at times. I know it’s being reworked for a future release. If you did edit the menu and you don’t have a new page, you might try changing the source to none and then back to the primary menu.

If that doesn’t help I have had to restart Blocs once to get the menu manager to respond again.


#5

Yes! That worked. Changing the source back and forth to “none” and “primary” cleared things up nicely. Thank you!


#6

happy to help.