Missing Assets AGAIN!


#41

Very good info @Norm, thanks for making this clear.


#42

I have encountered this issue same as you are again and again. I have already consulted this with @Norm. Hoping will have this fix :frowning:


#43

I’m preparing some in depth knowledge base articles on this issue as there are a multitude of scenarios that have different repercussions and various fixes or steps to avoid this.

I have been trying to improve asset management regarding the assets not loading, the issues tend to stem from security limitations with WKwebview which Blocs uses for the design canvas and asset manager. There are various fails safes built into Blocs to get around this but various asset management setup cause different issues.

What generally works all the time is to run Blocs from the Macs application directory (which needs to be on the Macs main HD) and to store all assets on the main HD also.

It tends to be external drives and services like Dropbox that cause all the issues. Sometimes drives are slow to respond, don’t have correct permissions, change path/url.

If images are listed but just don’t show this means they are available they are just being blocked from being loaded as the are coming from a different source to the one Blocs is run from.

But to summarise, this is somthing I’m actively working on improving and making more flexible.


#44

I’ve updated to macOS Mojave 10.14. First test seems promising! Hope this does the trick.


#45

When I run in to problems again I will put everything on my internal HD.


#46

But @Norm, right now I have limited storage on my HD that’s why I’m using External HD to work on. So with my projects like the one I’ve sent you has alot of images used… Right now I have experience several issues that images are available in app assets manager but not loading on the .bloc file when opened. Tried everything but unable to re-upload my files because it prompt that it’s already available. Likewise, you might want to consider us users using External HD because I’m handling alot of my project with it. Hope you can find the fix to this issue because I have a big problem with this so many months now. Actual I’ve tried putting the files and .bloc file to HD but same as it is still doesn’t show or fix the problem. I think it might be the overall file already :frowning: I’m furious about this because I need to secure all files to the .bloc file I’m continuously updating…


#47

There is an external drive handler already in place but it copies the files from the drive to the device in the background temporally.

I think your project needs special attention as I think there is an error in the actual file. I’ll follow this up later today via the original DM :+1:


#48

Thank you so much @Norm, you’re the best! :slight_smile:


#49

Actually I just had another idea.

Try breaking the image links.

so make a copy of the project on local HD, now copy all images to drive but under a new directory name images2.

Disconnect the external hard drive so original assets aren’t loaded, you should now get the missing assets window when you start the copy of the project on the local drive.

Reconnect 1 from the images2 directory and the rest will auto connect.

I’m not sure this will work but it’s worth a shot.


#50

I’ve already tried this. Still not working… Also the process to rename the entire materials folder to reconnect it hehe


#51

All of this sounds like a good case for storing web images remotely on the server before adding them to the asset manager. If HD space is an issue large originals can then be stored anywhere and it should just work.


#52

Worth a try.


#53

@mackyangeles Do you use the new Mojave Dark Mode? I’ve updated to this version and until now I don’t have the ‘missing assets’ problem. Maybe this can help… Good luck!


#54

Same here, I’m using the MacOS and still no fix…


#55

Hello, I’m very new to Blocs and so I have a very limited experience and practical knowledge at the moment. Nevertheless I’ve already enjoyed to dive into the app and found it very well to use.

I stumbled over the “missing Assets” problem, too. It took me a while, but I was able to find the problem in my case:

I’m using an external HD for my files. I realized whenever I try to import files with an apostrophe, like in “peter’s image.jpg”, all my files in the assets manager and in the blocs file disappeared (listed, but don’t show up). I wasn’t able to get them back, even if I deleted the one file from the assets manager. So I closed blocs and reopened the blocs file in the prior saved version.

Once I renamed the image file to “peters image.jpg” and imported it into the assets manager, it worked fine.

Importing the file with an apostrophe from the internal HD worked fine, too.

So, working with an external HD + having a file with an apostrophe in the file name causes problems when importing into the assets manager.

I hope that it helps a bit to find a solution to the problem.

PS: I’m using Blocs 2.6.4 and Mac OS 10.14


#56

I think there is a bit of a cache problem at times with the asset manager, so changing the file won’t automatically change the image. Changing the file name does the trick. I’ve actually seen the same with other apps.


#57

Yes, outside editing is a mine field. Blocs should flush the cache for you if you close the project and re-open not ideal but its better than renaming all your assets.


#58

Me to missing Assets… Its drama! Have to start over AGAIN


#59

Don’t you get the missing assets warning, that lets you reconnect missing assets.