Missing 'webp' file

I have updated to Blocs 5 and now when I publish my site some of the photo’s are not loading. I have tried heaps of stuff to try and get them to load, adding them again into asset manager, embedding the image, renaming it. Anybody got any idea why its not processing them?

Are you adding the images as jpgs and letting Blocs handle the conversion to webp or adding webp inside the asset manager?

Yes adding as jpg and it is producing the webp file, I have also used the same photo elsewhere on my site and it is showing there. It’s also not all photo’s just a few that I’m using as links to other pages…

The WebP naming appears to be wrong…

it shows … .JPEG.webp, if you edit the url to remove the JPEG part of the name, the image shows.

@Norm will have to check in here.

I would avoid spaces in the file names though. I do wonder if it’s the capital letters being used for the file type? Wait for Norm I guess. :smile:

@Kathryn300 Best general practice is not to use capitals, special characters or spaces in the image filename. The Jpeg extension should be .jpg and not jpeg or .JPG.

1 Like

Why is it picking on those particular images all my image filenames have capitals or space and .JPG, but just those particular images aren’t appearing. I have renamed those images through the blocs asset manager with no capitals or spaces and it has renamed it with .JPG and they are still not showing.

A @webdeersign suggested, capitals, special characters and spaces are not good and should be removed. You may even be having a cache issue here on your machine at the moment if those points have been fixed. That can often be resolved by restarting the computer. I did notice a while back that some images were sticking in edit mode cache, however appearing correctly in preview or when published.

I see that image ok on my system. Using inspector I can see that the image is https://badams.co.nz/img/Brendan%20Adams%20ceramic%20Sculpture.JPG.

Some browsers may not be able to display an image like this, so to avoid this fact of life, it should be renamed to something like Brendan-Adams-ceramic-Sculpture.jpg.

Also, as a precaution, it would probably be worth deleting all of your images and re-naming them correctly, and then get Blocs to generate new webP versions of the correctly named jpg images.

Well spotted I think the capitalised file extension is tripping Blocs up.

I shall get that sorted.

hey @kjwolf78 you can turn off WebP until I get this patch up. Sorry for the inconvenience.




I have also had this issue, but only when including assets from a URL. I have never had this from embedded assets.

Thank you for this, I was guessing that was what Alt text was. Good to have it all explained so clearly, and also the file naming practice, that would have been good to know a few years ago when I started my website now with 700 images its going to take awhile to get that all in order.

1 Like