Mobile view is tablet view


#1

Hey, I have some problems with the mobile view. Thing is that on my page the phone view is not displayed instead its the tablet view.

I figured out it has something to do with my domain service provider since I tested the following: I renamed the index.html and entered the absolute path on my phone and it worked.

Then I checked the domain settings from the provider and changed the frame-redirect to a http-redirect and voila, it worked on my phone like it should.

But I don’t want to see all the absolute paths of my website in the address bar. So is there a way to solve this problem? maybe with extra code to display the website URL only?

Regards Yann


#2

Could you attach some pictures? It would give me a better idea of what you are talking about.


#3

mh there is nothing really to show. It’s just like I said that with the frame-redirect the tablet view is is displayed (of course it doesn’t look good on the phone but when I change i.e. text in the tablet view it will displayed on the phone. so it’s the tablet view.

And like I said with the frame-redirect it doesn’t work with the http-redirect it looks like it should on the phone. The only thing that bothers is that I see the full path in the address bar but I only want the URL like with the frame-redirect.


#4

OK, I’m trying to understand what you are saying and I think I’m getting it.

So you have URL masking (also known as framing or cloaking) turned on for your domain?


#5

Exactly I want to mask the URL and put on the setting in on the service provider website. But with this option activated the phone shows the tablet view. Strange but true. When I change it to http-redirect it works but I want to hide the URL and only show the domain name…


#6

Oh oh oh, I see what you are saying now. Sorry, its easier to me to grasp things visually, that’s why I wasn’t understanding it at first.

I have the answer to your question. I have messed around a lot with masking for my site and so I have run into this problem too and have attempted to resolve it. What you are seeing is not the tablet view, the site is actually just blown larger than it should on mobile. This effect looks far worse on your site if your site has pictures. If you were to view it on iPad, you’d see a similar thing happen. So, how do you fix it? You can’t. You either live with this problem or use HTTP redirect.

Actually, the proper way to direct traffic to your site via a URL is to use an A record (for IPv4 addresses) or AAA record (for IPv6). That’s if you know the IP address of your site.

Let me know if you have anymore questions.


#7

thanks for your help already. So wait, does that mean that its not possible at all only with this A record? On my providers page there is both so A and AAA and others like cname or mx. I can also add a record there.

So what do I need to do from here to make the “real” phone view possible?


#8

It is not possible to fix your site’s “bloating” if you are using masking, you’ll have to find another way to route traffic to your site such as using A records.

If you have the IP address to your site, I can help you set up the proper records here right now.


#9

Well I think I have the address since under DNS there is a record entry with a IPv4 address for A and IPv6 address for AAAA. So what do I have to do now?


#10

Did you remove all redirect and masking settings? You should probably do that first.

Who’s your DNS provider by the way?