"navigate to page" doesn't work after export


#1

I got some strange problem: I set button to “navigate to page” and it work perfect inside the blocs app. When I click the button inside blocs app - everything is fine - the page I need is opened.

But when I export the project as html it changes - when I click the button it opens Finder with the page file I need.

What is wrong?
NIIIS-14-1-test.bloc (1.6 MB)


#2

It appears you have selected the home page for both the 2nd and 3rd link on your Nav Bar, so it’s not going anywhere…

Underneath the ‘Navigate To Page’ field, you see the ‘PAGE’ field…here is where you select from the list of pages the page title you wish to navigate to.

Or do you mean other links?


#3

Thank you for your attention to this problem!

I mean the link on “Processors” button for example. When exported to html it doesn’t open corresponding page in browser, it opens folder in finder in some reason.


#4

When you open the page in the bowser what is the link that the button is referring to.
and what is the link of the processor page in your internet browser.

did you have the clean url checked or unchecked when exported


#6

the blocs with the vertical blue lines on the Layer Tree are in your Global Footer area…so move what isn’t suppose to be a footer on all pages up, and see if that fixes things. (the ‘processor’ link is in bloc-2…is that suppose to be a footer element?).


#7

Thanks a lot, but I can’t figure out how to move these blocs from Global Footer Area. Cant see any ways to change it


#8

collapse all the blocs layers, then select a bloc in the Layer Tree, then pass ‘command’ + ‘option’ and use the up/down arrows on your keyboard to move or reorder them.

Global header & footer blocs will be at the top & bottom of the layer tree, respectively, with the blue vertical lines, all other blocs (with grey vertical lines) are only on that specific page.

also, be sure to set in the lower left corner of the layer tree the setting to see the bloc IDs to make it easier to observe them moving up or down. This is how your file is currently set, but knowing this is helpful, along with the other options you can control there.

Untitled


#9

Thanks again, I succeeded to remove blocs from Global Footer Area, they are now marked with vertical grey lines.

But the problem is still on - link outside of the blocs doesn’t work, it just opens corresponding folder in Finder

I guess I’ll have to remake the project(


#10

oh darn.

I can say this: when I try to preview-in-browser from your home page, blocs will not do it, nothing happens, no browser is opened…and so I switched to your ‘processor’ page to initiate the preview-in-browser, and that worked, the browser opened and I could see your processor page…then clicking to your home page from the processor page worked, too, and then using the ‘processor’ link on your home page did take me back to the processor page…so perhaps something more is happening with either the file or perhaps your computer??? This is beyond my ‘pay grade’ to use an old expression.