New Divider bric

@Norm
When I create a new project I can get the new divider bric to work fine, but if I use it in an older project it doesn’t work properly at all i.e. the height setting has no effect whilst the colour and width setting work fine. Anyone any idea why this might be the case?

If you look at the red divider on this test page the height is set to the default 1px which it clearly is not and regardless of what height is input that is what I get:

https://swiper.pixelarte.co.uk/test/

You will need to remove the divider and re-add it to your project.

@Malachiman
I tried that countless times to no effect.

Your test page seems to have 9px of padding ?

@Malachiman I’ve tried it with no padding but it makes no difference.

The .divider-h is the class in question and it looks like its under custom css. So either you or another thing is adding it. Looks like you have a massive pile of scripts attached to that page too ?

Something is giving it padding of 9px. :thinking:

EDIT: I think it’s Swiper which causes the trouble.

Delete padding on class “divider-h” and you will have the 1px in height

@Jerry I have just changed the page so it just contains a standard paragraph bric and the divider bric but as you can see the height is still the same and the colour setting isn’t working now either (it’s supposed to be red). Only height settings above 20px have any effect.

https://swiper.pixelarte.co.uk/test/

Check your custom class list for .divider-h and delete it.

And lots of other stuff is still hanging around there:

Where is that coming from?

That worked.

Check your project attachments in project settings or delete it from your server.

1 Like

When I do that the divider disappears. The @Alpha suggestion does work however.

See above. I mentioned either you had added the style or something else. Delete all the attached scripts that are doing nothing apart from one of them creating errors. (At least that one’s trying to do something :joy:)

I need to keep the scripts in order for those things to work on the test site I’m building, but at least now have a workaround.
Thanks for your input @Malachiman and everyone else.