No sitemap?


#1

Has anyone else noticed no sitemap on project export?
Carousel and or images off center to left? (Check against Grid “g” key)
I submitted a support ticket.


#2

Are we talking about Blocs 2 or 3 here? New project or migrated?


#3

Blocs 3. The XML sitemap used to be in the export folder.


#4

Did you check project settings?

screenshot_879


#5

Yes. Just try an export and look in the folder. Maybe it’s just on my system. I checked several different site exports…no sitemap. At least I couldn’t find it. It’s 5am here…so maybe that’s it. )


#6

Give me a minute and I’ll try. I personally use another app for sitemaps, but I know the address had to be included in project settings or the sitemap is omitted.

screenshot_880


#7

Great…I had to use another sitemap generator that also creates image and video Sitemaps too. But the Blocs url sitemap was good too.


#8

Just tried that and it’s there on export using Blocs.

screenshot_881


#9

Okay something going on here then. I’ll mess with it a bit. Thanks. New folders in there I see. Norm did a nice job on the code structure. :+1: thx for checking.


#10

I personally use Scrutiny for sitemaps but I imagine most will just want to tick the box in Blocs. https://peacockmedia.software/mac/scrutiny/

From past testing I know that lazy loading can interfere with sitemap generation, particularly in regard to images and video etc, so I would suggest you turn that off in the export settings before creating a sitemap. Afterwards you can export again with lazyloading enabled and leave the sitemap in place on the server.


#11

Got the site map to work. Shutdown the app. Reopened turned off generate site map turned it back on. worked. See before and after.


#12

Thanks for checking it for me.


#13

Sounds like a weird glitch with no explanation, but it’s surprising how often these things can be fixed by restarting the app.


#14

Unfortunatly this did not work for me.
Still no sitemap here.


#15

in the project settings try removing and entering something…I just put blocs3 in there.

and like Flasman said check “generate sitemap” its not checked in this screen shot but it should be checked.

screenshot_879


#16

That does the trick.
Thanks HMM


#17

Sorry if I didn’t say in the 'Web Address" …glad I was able to help.


#18

3.0.6
There is still no sitemap after export.
tried all given hints without success.

Anyone out there having more luck?