Open Graph FB not working after upgrade from Blocs 2 to 4

Hi friends!

I am doing something wrong perhaps? I’ve tried both the old way when putting the OGP code into the header and the new way, when Blocs let’s you upload a card in the settings.

Any ideas?
Skärmavbild 2021-09-10 kl. 23.53.05

Try scrapping your site through FBs developer tools. It also updates any cache they have stored.

Simple scraping may be sufficient.

Thanks malachiman! I tried it already! :cry:
I changed the index page in the blocs project. Can it be something with that?

Your Canonical tag is messed up, you have your domain name twice.

Also I have found sometimes you have to scrape a page a couple of times.

I thought it looked wierd! Where in blocs do I de-mess it? :clown_face:

Blocs gets the URL from Project Settings, check the URL you have there.

Hm…I’m checking but can’t find any URLthat looks like what it says in the debugger.

Put your domain name in the web address there. And preview the site, inspect the HTML, you should see in the header section the canonical link. Check its correct. Otherwise, do you still have some OG stuff in the page header left over?

Oh, thank you so much Makachiman! I love you and this forum! The card doesn’t show when I post it to my wifes on messenger but I guess it takes a while before it turns up?