Page settings will not open (Solved-but please see notes)

Hi all,

When ever I go to the page settings - Blocs just freezes and I have to close down Blocs and re-open it.
This happens on all my projects and also on a new project too
I get nothing at all when I select page settings

I have filed a report - just seeing if anyone else is getting this, in case there is a simple fix !

lates Catalina. MacBook pro 15" 2015

The screen goes dark and I do not get the page settings section come up at all…it acts like it is at times, but it’s not there and I need to totally close Blocs down.

edit 1:
Just re-installed and problem still there.

@Norm - its as if its trying to open and page acts like its open…but nothing pops up like usual, and I have to close Blocs down and re-open it to do a page.

edit 2:

I have downloaded 3.5.4 beta build 3 and still doing it on that too.
Something, somewhere does not want me to open page settings!!

Gone back to 3.5.3 as whichever one i use, it wont work.

edit 3

Backed all my projects up, took 100% everything I have to do with Blocs off my mac. re-downloaded blocs and still page settings does not open!..very strange. I will wait for Norm to get back to me now.

1 Like

I’ve replied to your ticket :+1:

1 Like

thanks - i’m on the case now ! (just had tea and saw it come in!) ill look now.


1 Like


Hi all,

Just want to say I have kind of resolved this. Basically as the post says - the Page settings would 100% not open at all, the screen would act as if it was opening, but would the page setting tab would NOT drop down.

Recently I have downloaded lots of free brics from the bric store to try various styles etc and also downloaded lots of bric offerings off this forum. I tried the brics but 100% did not use them in a project at all, but they are sat there in the bric selection.

Since doing that my Page settings would not work. I tried everything from deleting Blocs etc but Blocs would still load in the Brics. I took all my projects off my mac and images associated with them and still would not open.

I then decided to remove all my brics ive downloaded and BOOM! Page settings worked!!!

So basically - if anyones page settings do not work, then please remember if you have added a bric and remove that last one.

Unfortunately, I do not know which one it is…and to be honest, im so relieved Blocs is working now that I don’t want to put them all back on, and will add them one at a time when i actually need them now and will trial it that way.

@Norm has been informed and has worked with me on sorting this out - and i’m sure he will look into why this has happened as it does seem to be an isolated issue I had and not common.

Thanks Norm for your time on this. I will keep assisting on the support tickets if you need more help.