Pictures, logos disappear after exporting the project and show a question mark


#1

i did create lots of image in my site and it worked well few weeks ago; suddenbtly the image appear in my bloc file but everytime i do export the project, all pictures will be transformed in to a question mark.

how can i solve this

thakns for your quick help. i am blocked now.

best regards

Olivier Crave


#2

Any updates on this issue? I am now having the same issue as of today.


#3

Are you using the latest version of Blocs?


#4

@ocrave @Builder_ID those your projects uploaded to a hosting?


#5

Norm,
I upgraded yesterday to Blocs 2.3.2, made a couple of text changes and exported the project.
Uploaded to my site and no logo appeared.

I went back to 2.3.1 and the same thing happens as well.

Not sure if it matters, but I have noticed only a few files get updated during export, while other files display the first date that Blocs generated an export.


#6

Yes, I am uploading to a hosted site. Everything was working, until yesterday.


#7

Does the site run correctly when you open it locally after export?


#8

@Builder_ID have you tried checking the “Permission” credentials on your Hosting? It should be 644?


#9

Yes Sir, file permissions are set to 644.


#10

The site runs and looks perfectly in Blocs.
It works perfectly when viewed in preview.
I re-created a new site today, and ALL the pictures now load with “?”


#11

The only time you get the missing assets is once it’s hosted on your server?

Try this, export project, navigate to the index.html file within the export folder, right click and open in your browser of choice.

If this loads locally without issue, then the images are breaking on transit to your server.


#12

Yes, the only time I get missing assets is when it’s being hosted.

I exported the project, I navigated to the index file within the export folder and opened the file
with browser of choice. It works great!

I have tried these FTP clients and failed:
Filezilla
Cyber Duck
Transmit
Classic FTP
All have yielded the same failed response.
I deactivated and uninstalled, then reinstalled and created a fresh test site and still broken assets.

Any ideas as to why they are breaking on transfer?


#13

Can I just check that you are uploading the exported folder as it appears internally with all of the sub directories such as img, js etc?

Its been known that some folks just drag all the images and everything else out of the folder and place them in the root directory of the server which doesn’t work.

What you are describing is a hosting issue, if what you exports locally works then something is going wrong in transit.


#14

Thank you ALL and Norm for your input and help.
I finally figured it out. The contents of the js folder, needed to be copied out to the root of the public directory. whew… I was getting worried there for a few.

Thank you for your patience with this noob when it comes to web sites.
Thank you for Blocs, it rocks!!


#15

No worries, glad to know you are up and running!