Problem adding local video w/2.5


#1

I am new to this program but have watched the videos here and youtube and gone through the knowledge base (surprised not to see anything regarding adding a video in the base). I am merely trying to add and learn how to use the various elements of the program. I do not want to put the video into the background. I have a drone aerial photography business and I want to display videos and stills taken on various sites.

In drop mode I added a video ‘place holder - bric?’ into a bloc in the global area without any problem .

I now (after numerous attempts) have a 2.5 mb mp.4 in the asset mgr but am unable to get it into either the video place holder bric? or the video sidebar setting window. It took me a long time to even get to this point. As mentioned in a previous post about video problem I could not even get it into the asset manager. I still am not sure how i got it in there despite following directions (from the forum).
I also can drag the mp4 from the asset manager into the bloc and a video bric appears with a centered arrow but can not get the video to play or even appear in the windows

As a final resort I put in an id and created a class and still can not drag the mp.4 into the sidebar or the highlighted video place holder.

Anyway there seems to be some sort of relationship established between the mp.4 in the asset mgr and the video bric. When i click on the video place holder it is now in blue and the mp.4 is also bordered in blue but I can not drag it to either place. Clicking on the + does nothing. When I click outside of the area the blue highlighting goes away as expected. I also have a jpg in the asset manager. These are the only two elements in the asset manager.

Twice when trying to get this dragged over Blocs locked up my entire system 10.13.3 40G. I had to hard reboot.

I am at a loss how to accomplish this, i believe to be a simple highlight and drag over without success.

I have the local / remote setting and I can view the mp4 via the project assets preview mode. So the video is present. When I drag the mp4 into the setting sidebar i see two arrows wrapped in a circle pattern.

After numerous attempts to drag the video into the placeholder (remember there are only two items in the asset mgr. A blocs video appeared and started playing ??? I deleted it and tried again this time the correct video appear and started to play. After deleting it and trying to reproduce my effort it no longer works.

What am I doing wrong?


#2

There might be a bug with dragging the video to the placeholder, support for that was only recently added and depending on the video format it can be iffy.

Remember videos won’t play in design mode only in preview mode (v) on keyboard.

Aside from that if the video won’t play it may be that it’s not correctly encoded as an mp4. I’ve seen movs encoded with some tools that still show as .mov in the info pane in finder.

This is how I add videos, drag the video from finder into the asset manager or directly from finder into the design canvas. Tap V and you can the preview it on your site.


#3

Norm
Thanks for the prompt reply. Tapping V solved the view issue.
Rich


#4

Yeah videos can’t be played in design mode, it would be a bit distracting :+1: