Problem since upgrading to the latest version of Blocs

Hello,
(I hope i have posted this is the correct place)
Since I have updated Blocs when I export and upload my website to my web server the images do not display and all links are broken.

I have check with the hosting people and they say its all fine there end.

I would really appreciate any help with this as I am running out of ideas.

I work on a mac running high sierra 10.13.6 and have viewed my site on various devices, but still the same problem.

My site is https://www.eekdesign.uk

thankyou
Richard

Hi @eekdesign,

Looks like you have 10 things missing (on the landing page anyway). Which includes the bootstrap framework as well.

Can you confirm these files are actually on your web server. Check your export folder also.

Also have you tried exporting to a new folder location?

Hi @Malachiman
thankyou for reply, much appreciated.
those files are all on the server and in the export folder. I have also tried exporting to a different folder.
https://monosnap.com/file/SaiJIxVoHT3f3mkrZrVlWkkN2p5DRc

Does your website work when viewed locally from the export folder? If it does, it’s likely a problem with the upload itself. I, like @Malachiman notice from your site that your images, js and CSS files are failing to load.

Check first the local version of your site in a browser, and iff all is well, it’s unlikely to be a blocs issue. If it displays fine locally, try uploading again, maybe using a different FTP application. Alternatively, zip the files in your locally published folder and upload the zip file directly to your public.htm folder on your server, You can then extract the zip on the server to ensure all the files are in place.

1 Like

Thanks @hendon52
when I open up the main exported index file this is what happens. (local version)
https://monosnap.com/file/Od2QhesyXRgUZWSPDPA9OjmuitKwn6
it jumped to the folder where the index file is for that page.

Hi @hendon52, @Malachiman i have just tried uploading a zip folder of all the files and I uncompressed it and its worked… thanks you for your help! much appreciated! You made my day big thanks :smile:

1 Like

Time to buy Forklift FTP :grin:

Great it’s working.

Glad to hear it’s ok now. Yes, the zip file option can often be more reliable than using FTP apps. If there is a break in the connection during transfer, all sorts of problems can appear. If in doubt, zip it and send it.

I’ve had this happen in the past with Cyber Duck. Since I changed to Forklift I haven’t had it happen.

I think it can happen with any FTP app from time to time. I use Cyberduck and occasionally I do get incomplete transfer errors. My host tells me its often to do with something they call “handshaking” between the FTP app and the FTP server. Fortunately, after they made a couple of tweaks at the FTP server end, this is no longer an issue for me. But, when FTP does go pear-shaped, I always fall back on the cPanel option of uploading a zip - works every time. A bit inconvenient if you’re doing a small update, but at least it gets the site online without issues.

I been using forklift as I am not keen on cyberduck, especially as its free, but in the past I used transmit which very good. I did try using cpanel but i didnt know about uploading a zip file, its a good trick that is. big thanks :slight_smile:

1 Like