Problem with Homepage Images not showing


Could someone let me know why the images/graphics on the homepage of my website do not display on Windows and Android phones, but do display on iPhones and Macs? Cant seem to figure this out, would appreciate any help on this.

Thank you


That’s strange, but it seems to be browser dependent on my Android. It works in Firefox, but not with Chrome.

Its very odd, i cant work it out.

I have had issues like this in the past, but with svg images and that was because I had saved without the curve.

As a test I just tried loading your logo on my server as a lone graphic with no web code and it shows up fine there on the Android, suggesting there is nothing inherently wrong with the file itself. I would be inclined to submit a bug report including the project file and as much information as you can add.

Hi @eekdesign, there’s an issue with the loading of the pictures. When I change the source to the full URL it loads correctly. Did you set up the web address correctly in project settings?

Hi Flashman, the site is been fine for a good year, its just recently that it has gone wierd. thanks for your replys.

Hi Jerry, this is a screen grab of the project settings.
Screen Shot 2021-02-22 at 11.35.28

Does it look correct to you?

Just add https:// and this should help

Hi Jerry, have just done this but still the same problem. (have cleared my cache)

This is browser dependent and not just platform related. I just tried Brave on my Mac and had the same issue.

It’s weird behaviour. When you inspect the element it shows now the correct path to the image but its still not loading. However, when you change the"img src" to the full URL it works like a charm.

I contacted my hosting people and they came back with the following:

I can recreate the issue in Chrome, and it’s due to those assets being blocked by the browser with (blocked:other). I’ve attached a screenshot showing the errors.

Unfortunately I’m unsure why they’re being blocked as it loads fine in Firefox for example. Chrome can also load the images separately:

You’ll likely need a developer to take a look, or to query it on the Chrome forums - But there is nothing relevant in the JS console which points to why it’s being blocked

Still no the wiser on how to fix it…

When I use your pictures and upload it to my hosting provider there’s no issue with page loading in Chrome. My first thought would be it’s a hosting issue.

Chrome had a bug years ago that stopped png files that had been resized from displaying. Maybe its back?

Is it perhaps again relative to your previous issues?

Thanks for replying and sorry for the late reply.
I have on idea how to to fix this. but thanks for your help

Something is certainly amuck, the images can be found directly but do not show in the images folder from whence they are referenced. In fact the image folder in which they are directly linked from can not be found.


Certainly ‘Krystal Hosting Ltd’ should a least be able to figure that out? Do you have some funky permissions, htaccess, server settings going on?

Hi blocs_User, i have been in touch with the hosting people and they were not much help, see previous message further back in this chain of message.

This is what is in the htaccess file:

SetOutputFilter DEFLATE # Netscape 4.x has some problems... BrowserMatch ^Mozilla/4 gzip-only-text/html
    # Netscape 4.06-4.08 have some more problems
    BrowserMatch ^Mozilla/4\.0[678] no-gzip

    # MSIE masquerades as Netscape, but it is fine
    # BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

    # NOTE: Due to a bug in mod_setenvif up to Apache 2.0.48
    # the above regex won't work. You can use the following
    # workaround to get the desired effect:
    BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html

    # Don't compress images
    SetEnvIfNoCase Request_URI .(?:gif|jpe?g|png)$ no-gzip dont-vary

<IfModule mod_headers.c>
    # Make sure proxies don't deliver the wrong content
    Header append Vary User-Agent env=!dont-vary

RewriteCond %{HTTP_HOST} ^[NC]RewriteRule ^(.*)$$1 [L,R=301]

That’s just about the weirdest htaccess I have ever seen and looks about 20 years old. Netscape 4???

Have you followed up on my suggestion to submit a bug report and send in the project file? You should reference this thread.

Hi Flashman, I thought that, its very old Netscape Navigator. I have not submitted a bug report. Who do I go about submitting a bug report? Thanks, richard