Program Crashes When Saving Font Specs in Project Settings

Hello, I thought I would mention an issue I’ve been having. I’m running Blocs 3.3.0 on Mac OS 10.14.5, Mojave.

I started a new project, went into the project settings to set up my font choices. I select H1, make some settings, then H2, and if I just hit enter or Done, the program crashes. I try again, this time maybe choosing H1, the paragraph and the same thing happens. I can’t seem to get all the way through H1 and another one before the program crashes. I’ve been trying to set up, for example, H1 then hit done and save, then go back in to do more since I can’t seem to set more than 2 sizes before it crashes.

My files are on my local mac hard drive, not in the cloud.

Not sure if I’m doing something wrong or if it’s a bug but I thought I’d mention it, I’ve tried with several different fonts and get the same result.


There used to be a bug in that caused Blocs to crash at start up if using El Capitan and I think it was linked to Woff2. Without Woff2 it worked fine and I wonder if you are seeing something similar. I’ve added a few fonts recently with the same set up and had no issues.

I’m not familiar with Woff2 but I do see it a couple times on my system associated with Adobe Creative Cloud. I wonder if it would mess anything up to delete it?

I’m not really adding any fonts, just selecting some of the ones available in Blocs. It doesn’t seem to make a difference which font I select, I’ve tried several different ones, same thing, it crashes. Then I thought it might just be with the H1 but it seems to do it with any of the sizes.

I did manage to start a new document, changed my H1 specs, saved the document, then did paragraph, saved and it hasn’t crashed yet. Now I can go into any of the sizes and make changes and it’s been fine.

Very strange


If it happens again it may be worth trashing the preference file and see if that fixes it. That was obviously not expected behaviour.