Quirks in Blocks?


#1

Hello All,

So I just purchased Blocs to use it to prototype websites that I can then finish in Pinegrow. I tried a few things and noticed that it’s behavior was a bit quirky. I’m running on El Capitan (latest release).

Here is what I have run into.

Navigation Bar: Changing the logo on the Navbar with Text changed the background image of the whole bar. I added the asset and then selected it. Tried this several times with the same result. Restarted Blocs and it then worked.

Navigation Bar: Changed the Text of the logo, Selected the option to view the Text Only. Went back to the Logo and Text and the Text was reset back to “Company”.

Colors: Tried changing a swatch color and it kept resetting to the original color. Closing the swatch box and reopeningi it seems to have reset it.

Not sure whats going on but it really makes using it not practical if someone has to try something 3-4 times before it works. Just wondering if its something that I’m doing as it seems pretty intuitive.

Cheers,

Vince


#2

So here is another issue that I have run into. Selecting the logo and trying to change the text color alters the text color of the menu item on the navbar instead of the logo text. I can select the menu item and the property fields change demonstrating that a different item is selected. I tried to attach a video of the issue but it wont allow uploads of an MP4.


#3

I’ll check these out today and see what’s up.


#4

Thank you Norm. Would really like to use the software and your new product that is in the works in my workflow.

Cheers,

Vince


#5

I cant re-produce this, the only time the text is reset is when I select image only because there is no longer any text when you select an option with text it has to be regenerated so its goes back to my company.
Try opening a new project and just adding a nav bar and setting the company name and then switch between text and image+text. It stays the same for me.

Sounds like the Asset Manager got muddle up, I just checked this and it works fine for me in 2.4.2, when you clicked the logo you may have somehow clicked onto the bloc background causing Blocs to think you are targeting the background image?

When you say changing the colours do you mean with the sliders, ie change the colour values or the assigned colour of an object?[quote=“vrooney, post:2, topic:2094, full:true”]
So here is another issue that I have run into. Selecting the logo and trying to change the text color alters the text color of the menu item on the navbar instead of the logo text. I can select the menu item and the property fields change demonstrating that a different item is selected. I tried to attach a video of the issue but it wont allow uploads of an MP4.
[/quote]

Just tested this and it’s all working fine in a fresh project, are you able to replicate this issue every time? If yes it could be a project issue in which case I will need access to the project to see what is causing it.

Thanks, and welcome :slight_smile:


#6

Hi Norm,

It’s not consistent. Shutting down Blocs and restarting corrected some of the issues. Also just closing the dialogs and reopening them sometimes corrected it. Just so I understand, When you select an object and the blue bounding box is visible (ex: logo selection) you can still be selecting the background by doing that? The properties lists the logo and text options including size, color etc. Could it be that it’s something to do with the selection area and the asset manager? I was under the impression that when the object is selected that it would be only its property changes. If that object is sitting on top of the background, it’s possible that the background can also be selected even though there is no indicator (blue bounding box) on the background? It makes it a little difficult to identify because the properties are only identifying one object (selected).

Here is a dropbox link to a video I created on one of the issues where you can see the change to logo text color (according to the properties) is affecting the menu text color even though it isn’t selected. Selecting the menu item changes the properties elements and the color change works correctly.

Thanks,

Vince


#7

Once again the board doesn’t like the link. Select the link without the quotes to download. It’s a 3M file.

https://www.dropbox.com/s/5s82w3t3o9w2qki/Blocs.mp4?dl=0


#8

Hi Norma,

My problem is exactly this one.

Navigation Bar: Changing the logo on the Navbar with Text changed the background image of the whole bar. I added the asset and then selected it. Tried this several times with the same result. Restarted Blocs and it then worked.

I need to resolve immediately, do I have any other solution than just restarting blocs?


#9

Vince the logo selection issue is fixed in 2.5.1 beta build 2. I fixed it over the weekend. It’ll be available tomorrow.