Scroll to Target inop?

Exported first site with Blocs 5. Using menu with scroll to target items. All works great in Blocs but when I export and publish to server as I do with previous sites using Blocs 4 with same type of menu, the menu on this new site does not work. And in looking at the URL when I click a menu item it ends in /# and not the actual full target such as /#contact. My other sites with same menu style work fine on the server so it’s definitely just this new site and I tested in a couple browsers and just won’t work… Not sure if it’s a setting I have to change now that I am in Blocs 5, but it ‘just worked’ in Blocs 4. Thanks.

*UPDATE - I uploaded an image from the page online showing the URL target is wrong (/#) and that it is set correctly in Blocs and should be exporting as /#bio. And yes, the target is a bloc with the ID set as bio :slight_smile:

*another update: when I view in a browser from VIEW in the Blocs menu, that works, too… so it’s on EXPORT that this is happening.

Is the original project created in Blocs 4 and exported to Blocs 5?
It tried to replicate your issue below but it works as expected when exported.

thanks for doing that, yep your works. So this was one of Eldar’s templates that he updated for Blocs 5. I will check with him. I will post any findings. Thanks.

1 Like

another update, so this time I exported full site (which is all fine in Blocs) and used Blocs new ftp to publish, and still doesn’t work. I did message Eldar, so let’s see if there is some residual Blocs 4 issue left behind in the template…

Just to be sure, did you empty your browser cache? Weirdest things happen when that’s forgotten.

yes, and on a couple computers, different browsers and mobile… I am going to look at this again as in Safari on my phone the text of the menu is not even visible. I can click the menu area and then the menu itself shows up but still won’t work… Not visible could just be the setting I have in Blocs for mobile size, but I will take a look. Thanks for the suggestion though :slight_smile:

another quick update, removed the sticky option for the menu and it is still sticky (when I scroll the page since the menu itself still does not work). Again, cleared caches, multiple browsers, multiple computers… :frowning:

  1. Afraid to update any other sites right now in case this causes issues, and also because of
  2. my post about local folders getting deleted when I update changes to the site locally, it deletes existing folders I created in the site folder to hold some files I upload from my FTP app. … I posted that under help also.

I am not GREAT with Blocs, but I have done these things many times in Blocs 4 with no issues… also one page I updated the scroll to target OVERSHOOTS and still have no solution for it. Some odd little things.

Temporary resolve! Thanks to Eldar. Any change in the template from Blocs 4 to Blocs 5 is fine. It’s got something to do with the server or how the FTP transfer is uploading… Eldar exported my Blocs project on his end and it worked fine on his server and he sent me his exported project (my site) and I uploaded and it worked fine also. I will look further into this, but should not be a Blocs issue at all and definitely not the template. Thanks again to Eldar. For now my site is working online, from his export :wink: Great templates & courses BTW. Not only are the templates excellent, they are helping me learn Blocs, too :slight_smile:

1 Like

I think part of the issue is Blocs. When setting a button interaction to “None” blocs exports a number sign as href attribute link ("#"). Somenthing which shouldn’t be there to my knowledge. @Norm? :thinking:

1 Like

A link needs a href or it’s seen as just text. # basically refers to same page.

still have not solved this in my case. Doesn’t seem to be any reason it should not work, but I’ll keep looking for a reason.

When interaction is set to “none” there is no link at all therefore it shouldn’t be there. Or do I really have a blond :blonde_woman: moment. :thinking:

You shouldn’t be using a link or a button for non-interactive element :wink:

1 Like

somehow I ended up playing with it so much I think it works…