Sticky footer is not working, please help

Hello everyone.

I would like to ask for help with the sticky footer. There was already talk about this in the forum, but for some reason it doesn’t work for me.
Can someone give a detailed description of it, step by step how to do it?

I managed to make the sticky footer work, but the links in the footer don’t work. No matter what I click on, it does nothing. :cry:

Hey @Boss81. Anywhere live?

What do you think?

Well. I’m only trying to help solve your problem. Apparently, that was not a good idea.
All the best with it and have a beautiful Sunday! :palm_tree: :coconut: :sunny:

1 Like

What’s wrong? I do not understand you…

Well we don’t have any details to help you. A live link can help diagnose the issue. All we can do is assume and then people have to commit a lot of time helping.

With a revealed footer usually it’s a z-index issue as the section above has padding at the bottom the height of the revealed Footer. So the links are behind the previous element and you can’t select them.

Also im guessing you have checked the browser inspector for any errors. Because if you’re using a bootstrap 5 project the code in the old thread won’t work without JQuery. :grin:

Good luck.

Unfortunately, there is no live link yet.
I am using Bootstrap 4.

I understand the error, but I still don’t know how to do it.

Maybe I didn’t put it in the right place?
Képernyőfotó 2022-07-24 - 8.34.07

Works for me bro. :innocent:

Kapture 2022-07-24 at 12.12.59

2 Likes

Perfect! :slightly_smiling_face:
I would like that too. Can you help with that?

I’m no expert, but looking at your CSS screen shot there’s a z-index of ‘-100’.
I’d start by changing that to ‘999’ or something quite high (without the - in front) to at least rule out a z-index problem.
As @Malachiman pointed out.

You can use the class editor if you wanted to. Most of that CSS was not in the class editor when the original thread was posted.

You would need a negative z-index to set it backwards. -1 will do though.

1 Like

Unfortunately, the link does not work.

If I take away the minus, the footer is in the foreground, so that’s not good.

I added the sticky footer in the class manager.

Exactly. People like to use random numbers with z-index when there is a proper structure in Bootstrap and also keeps everything tidy for potential problem solving.

Every time I see someone use 9999 :grin:

Yup.
A respected Custom Bric developer ( Hey @Malachiman :grin:) taught me once:

Z-index is tricky to get your head around as it’s relative. So you could have a 1 that is higher than a 6000.

Some interesting read about it here:

1 Like

Here is a video showing the problem.
What do I do wrong?

Hi @Boss81

I assume you have set each link’s Interactions to Type: Navigate to Page & Page: to whatever pg you want to go to.

Also check Blocs Preferences > General & set Preview Type to Local Server - that fixed it for me.

Have fun.

Bill
BricsDesign

Hi @Bill

I tried what you said, but unfortunately nothing changed. :cry:
But thanks for the idea. :slightly_smiling_face:

Hi @Jerry

I was thinking, if I ask you, could you share the block file that you made the video about, so that I can check if it works for me or not?
It would be a great help and I would appreciate it.
Of course, only if you don’t mind and it’s not a big problem.