Strange behavior duplicating blocs


#1

Building a page that has a row of buttons on top that will scroll to a certain bloc with the scroll to target function. I duplicate a Bloc, then fill it with my info. When I duplicate it it comes up as only Bloc in the left menu, dont have a number and does not show in the right menu under scroll to target (where I choose the Block that the button should scroll to). I notice it does need to be numbered to show up there. If I visit other pages in my site, work on some other stuff, then after a while comes back to that page, its OK, it has a number and can be choosen as a target. But not right after I duplicate it, it takes sometimes several minutes for it to “become” a bloc with a number in the left menu. And it seems if I stay on that pages it won’t happen at all.


#2

To add my 2 cents.

I have also seen some strange behaviors with duplication blocs whereas you select items in the duplicated bloc and the refer to the original bloc on the right hand side tree. Perhaps was it in the first versions of Blocs 3 - I’ll check again and report if needed.

MDS


#3

I got the new version, 3.0.6. It does not do that though.

I just tested again, working on the same page for over 10 min. The latest duplicated Bloc did not get a number, and was not selectable as a target. Then I switched pages for a while, got back the the page with the error and then it had the number, ands showed up in the target list at the right. Some kind of updating problem.


#4

I have been dealing with this for a while now since it works…after a while. But now, when I needed to duplicate a block in the middle of the page that has about 60 Blocs, the Bloc number on the new Bloc has the same number as an old Bloc (Bloc #54). And I need to link to that Bloc from another page. What to do?


#5

These are the Bloc IDs you can set these values in the right sidebar at the top. Blocs auto generates them for you on export.


#6

Great, that fixed it, thanks!