Switch to local fonts


The first warnings are just fluttering around the ears of my web designer friends in Germany. That’s why I’m stepping on the gas now when it comes to switching to local fonts.

And now I have a problem…

Can someone please tell me why I still have all the googleapis.com-lines of code in my header on all my webpages even though I switched them all to local fonts (as Eldar showed in his video)…Got the google web fonts in the corresponding formats (woff, woff2, ttf, svg, eot) loaded locally in Blocs / Google Fonts switched off / restarted / everything on the server overwritten!

What am I doing wrong?

And does anyone know of a test page where you can test the actual connection of your website to Google?

Thank you in advance

Dumb question perhaps but have you cleared your browser cache?

You could also block any connections to Google fonts by adding this line to your htaccess:

content-security-policy: font-src 'self';

Yes I have… and the plug of my computer was also in the socket! :stuck_out_tongue_winking_eye:

Sorry, I’m not a programmer but the html lines of code should be out if I have deactivated google webfonts…Or does it only work for newly created websites?

THX…I‘ll try that if the deactivation doesn‘t work.

The code linking to Google fonts shouldn’t be there if you have disabled it and switched to local fonts. My guess is that you have a forgotten custom class somewhere that links to Google fonts.

You can always send in the project file with a bug report to have it checked. In the meantime that htaccess should block any connections to any external servers for fonts.

This happened to me and it took me days to find out what it was.
I found out that it was a little span somewhere what caused it.
Also have you deleted the google fonts from the Blocs font manager?
It’s not enough to just disable google fonts.

1 Like

You should be able to spot it in your exported CSS file with a quick search. Find the class using it then search your html files if your unsure where it is.

1 Like

Great - thanks…that worked for me. After the restart blocs noticed that the google webfonts are missing. :wink:

Now all the googleapis.com-code lines are out!

1 Like