System requirements for Blocs App


#1

Where does one find system requirements for Blocs?
All versions all be helpful. I have a MacBook Pro 2006.


#2

@KBConcepts MacOS 10.10 minimum is the only requirement.


#3

Hey Norm, thanks for taking the time to answer. I would have responded early, but did not get any notification.
A friend of mine can only run Leopard or Snow Leopard, since he cannot afford a newer model, so I ask what version of Blocs can he run. Oh yes, I almost forgot. How does one get an older version?


#4

I have an old iMac from 2007 running El Capitan that I keep as a backup. Will that still be OK for Blocs 3?