Text pasting incorrectly into Blocs


#1

When I paste certain text into Blocs text brics it is rearranging the text. This does not happen when I paste the same text between other programs (such as Word, Excel, etc…). So my question is, how can I have blocs paragraph bric behave just like these other programs?

The animated .gif below shows me placing 2 paragraph brics into a fresh Blocs project. In the first case, the text copied from Word transfers as expected. But in the second case the text rearranges.

It’s easier to see if you click on the image first. Also, I’ve circled in red the portion of the text that rearranges in the image below: text that was after the Roman numeral I at the end of the original text moves to the front of the text. It’s really frustrating because I can’t even fix it by editing the text within Blocs.

I realize this problem has something to do with the fact that the language I’m pasting reads from right-to-left, and the text is being interpreted as a mixture of left-to-right and righ-to-left text. But what puzzles me is why I can’t get Blocs text brics to behave just like text is treated in programs like Word or Excel?

I’ve tried changing the language of the website using the Blocs preferences but that doesn’t seem to have any effect. Also, I’d like to be able to use multiple languages so I want to learn how to make the Blocs text brics work no matter what language I’m using.

If you want to try it yourself, here are the 2 portions of text I use in the animated .gif:

الفصل ٣–صلاح الأرض - علوّها

الفصل ٤–صلاح الأرض - غناها الذي لا يُستقصى I. الماء

Notice that the second one has rearranged here as well even though I pasted directly from Word!

Thanks for the help,
-Tony


#2

Hi @Tony

There is already something strange when trying to select your text on this post as you can see below it jumps:

MDS


#3

Thank you for your reply @MDS

I think I may have discovered the solution.

  1. highlight the text bric
  2. add the attribute ‘dir’ value ‘rtl’ as in the screenshot below:
    08%20PM

Alternatively, you can select the RTL option within a custom class as shown below:

I hope this helps others.

-Tony


#4

Hi @Tony,

In case you missed it there is also a setting for RTL found in the project settings.
https://help.blocsapp.com/knowledge-base/rtl-text-direction/


#5

Yes, that would apply for a website that was all RTL, but my site is multilingual.


#6

When working in website building applications, always paste text as ‘plain-text’. Formatting inherited from word processors is causing problems with formatting within website builders.


#7

If you put your cursor within a text bric and look into the edit menu the only option is “paste”.

In other words, I don’t believe there’s an option for pasting as “plain text” within a blocs bric. Also, I don’t believe this applies to my problem, which as I wrote above, has been solved.

Thanks


#8

Hello,

In Blocs, when you paste text, it strips it from all formatting automatically. :slight_smile: