The Bloc file is now 2.43 GB (!)

Hello to everybody,

I used the inspiration template from Blocs templates to design a new website for our school. Everything worked wonderfully. However, I must have made a silly mistake while saving or importing files. The Bloc file is now 2.43 GB (!) And I can’t find the error. Is it possible to see the individual files that I have integrated and partially delete them again? How can I get the file size back to normal without having to start all over again?

Thank you very much for the help!!

When you say the “bloc file” what exactly are you referring to?

The only thing that comes to mind with might account for a actual project file (i.e .bloc) file to be that big is possibly you have a huge folder of source images that you have somehow embedded in the project?

Nothing else springs to mind. Perhaps others will have some ideas.

I have to agree with @Erwin there’s something mysterious going on with Blocs files after a certain number of pages. I have (had) a website of about 50 pages and the file was already a massive 1.3 GB. Photos embedded but all slimmed with ImageOptim. This morning I added one (1) page and the Blocs file grew to a whopping 2.52 GB. There’s something weird going on which needs research from @Norm.

Don’t forget to make a support request. It’s guaranteed to get a look that way.

Done! :+1:

1 Like

same here…
.bloc project went from 1.02gb to 2.03gb with just a few small changes, I reverted to old version with time machine & made same changes & is now 1.02gb.

Please make an official support request. I’m sure it’s either correctable or explainable, but I just don’t have any answers at the moment.

Hi @andrew, the 2.52GB file as mentioned earlier grew to 4.9GB by adding just one picture. @Norm is on it!


I had the same issue with a couple of sites (V3). It seemed every time I saved a change, it was put ‘on top’ of the project file, rather than overwriting. By the time the file reached around 5GB, it was taking about 2 minutes to open or save the file.

I solved it by copying the problem file, opening that and saving it. I renamed it to the original file name before saving.

That worked for me, but obviously I would recommend you back up/ copy any files before trying it.

Welcome to Blocs, @Erwin!

Are you and @Jerry embedding assets within your Blocs documents, or you do link to assets?

I ask because I always link. I never embed. And so far, none of my large Blocs 4 documents have grown beyond 33MB in size. I link to well over 200 images and the total size of all those images comes to about 13.8MB.

I am wondering if your unusually large Blocs document filesize problem might be a bug pertaining to embedded assets. I also don’t know if OS is related, but I myself am on High Sierra.


Silly question, but I remember something like this happening on another app when the project file was on a google drive, iCloud Drive, etc. Is your blocs file on a “cloud” drive?

Hi @JDW, all files are embedded. @Norm is on it, Its just a weird behaviour.

1 Like

I have embedded assets since using Blocs 4 but not prior to that.

Why do you never embed? I thought that’s a nice feature. What are the Pros/ Cons for just linking or embedding?
(besides the bug now when embedding)

Im investigating the file size issues. Hopefully more info later in the week.

1 Like

I dont think the bug is related to embedding assets.

When you embed you’re “bundling” the assets into your actual project file. When you distribute that project, those assets go with it.

If you don’t embed, basically when you open that project file on another Mac you’ll need to use Blocs feature that finds the images which you’ll have placed somewhere on that machine.

many people don’t need to open projects on different machines I suppose. I’m curious other users reasoning for not embedding?

Embedded assets do not show refresh or show in finder options with the asset manager. Also, does the asset have a link symbol? that means it’s externally linked and embedded assets do not have any symbol.

I have used embedded assets once and once only, then went straight back to the old way. The assets are either stored remotely on the server or in a nearby resources folder. If the project needs to be sent with assets it can be generated as a package.

As an afterthought if you store the projects in iCloud all the resources are automatically available to your other computers alongside the project files.

1 Like

Thanks for that explanation @Flashman. Templates typically non-embedded then I suppose?

I guess. I’ve never used templates. My draft projects I use as a starting point don’t use embedded assets.

From memory I struggled with changing embedded assets, yet keeping the same name, because it continued to show the old image and I couldn’t refresh them in the asset manager. I just remember that it all became rather frustrating.

I keep working or recent projects inside iCloud on the system hard drive with various backups. Legacy projects with assets can then be zipped, locked and placed on external drives again with backups.