Unwanted third-party request - googleapis


#1

@Norm
Hi there,

First of all congratulation for Bloc 3! I use Blocs since the early Version 1 and I’m really impressed about what you developed so far…

Unfortunately, I have to report an issue regarding the use of local hosted fonts:

I removed all Google Web Fonts (in Blocs 2.6.5 and 3.04) under „Preferences > Manage Fonts“ and I disabled „Enable Google Fonts“ under Project Settings. I’m using only Local Web Fonts (in this case Roboto) downloaded under: https://google-webfonts-helper.herokuapp.com/fonts

Despite that, there are still 3 third-party request from google affecting my website (see below).
I checked the generated HTML code for index.html and I discover the following line of code (see below).

Is this suppose to look like that? How can I get rid of the google requests?

Best regards
Michael


code


#2

I had a similar issue in Blocs 2 but I’m not sure its an issue with Blocs itself but if Blocs is set to Disable Google Fonts, then Blocs should revert all text to a local web font at least? I used local web fonts, then I switched back to Google Fonts, and then after I switched back, some fonts didn’t seem to fully switch, and I had several different fonts in my project I had no idea about, with google trying to fetch a font and then timing out or something.

My only fix was to change the Style.css and rename the font family to the correct one, that was until I found the font hidden in a paragraph somewhere which I immediately changed.

Double check your project, every detail of it and make sure all the fonts are selected as the Local Web Font Roboto.


#3

Interesting, thanks for bringing this to our attention. I have a question though. If I remove all web-based fonts and install local funds do I still need to be connected to the Internet in order to use Blocs 3?


#4

No need for an internet connection when using local hosted fonts.


#5

Is there any cool links and or video tutorials on how to do this in Blocs 3?


#6

You can remove/add Google Fonts or Self Hosted Fonts under: Blocs > Preferences > Manage Fonts (see screenshot)


#7

Short of manually removing that link tag in the header after export, I’m wondering if maybe your local web font paths weren’t correct and maybe Blocs is adding the google path as a fallback, just so it will work. I don’t really know, just guessing at this point :wink:

And the dropdown really should say “Self-Hosted Web Fonts” - I’m a stickler for detail :wink:

Bill
BricsDesign


#8

Hi Bill,
Thank you for pointing the dropdown aspect out. In my both versions (2.6.5 and 3.0.4) it says “Local Web Fonts”!
Am I the only one with this particularity?

Thanks guys!