Using Blocs 2.3.2 and Beta alongside each other


#1

The icon sets have been updated for use with Blocs 2.4, this makes them non backwards compatible. In order to use Blocs 2.3.2 and 2.4 on the same Mac you will need to do the following after you have run 2.4 for the first time.

• Go to this location Library/Application Support/Blocs 2/icons/, you will see 5 icon directories within it.

• Now download this and unzip it. If you look inside you will see the same 5 directories. Within each directory there is a file labeled collection.json. Copy each of these files from the respective directories into the same directory that resides within the Library/Application Support/Blocs 2/icons/ area on your Mac.

As of Blocs 2.4 the icons are loaded from another file called iconSetData, Blocs 2.3 and lower loads the icons from the collection.json file. All you have done is make sure Blocs has access to both file types. So within each icon directory you will now have a iconSetData file and a collection.json file along with the font and style directories.


Icon Font manager Blank
Blocs 2.3 Bug
#2

@norm thank you. It worked like a charm. Icons in both versions, I’m a happy camper…

Casey


#3

Hi I can’t find Library/Application Support/Blocs 2/icons/ on my mac. Even deleting both versions and reinstalling the old version of blocs, the icons wont work. Pls help.


#4

@drumster81 click ion the desktop so finder is active, then go up to the menu Go and when that menu drops down hold the ⌥ (alt/option) key and you should se the Library.
It’s that library you should go to.

Or use the go to folder (shift+cmd+G) and paste: ~/Library/Application Support/Blocs 2/icons


#5

I found it! Appreciate your help so much!


#6

This fix doesn’t work. Any idea how? the arrows on my Carousel/Slideshow just vanished.


#7

hey @mackyangeles , are you fixed are not? in the other thread you mentioned its working now??


#8

Yes @Norm, it’s fixed already :slight_smile:


#9

good to hear my friend :slight_smile:


#10

Good morning, I missed the above procedure and lost the “file icon Set Data file”. So in the final version 2.4 I find no icons, can you help me?


#11

If your Mac has more than one drive, take a look at this it may help.


#12

Ok thank you so much, I solved it.


#13

Hi,

I have used the beta version of blocs and the 2.3 side by side, all worked fine with the icons. Today I downloaded the released version of 2.4 and now I have no icons in the icon font manager.

Any ideas on how to fix this?
//Cissi


#14

Check the icons directory in your application support > Blocs 2 and make sure you have iconSetData for each set.


#15

I dont see any folder/file like that.


#16

Could you upload a screen shot of what inside this directory Library/Application Support/Blocs 2/icons/FontAwesome


#17

Mine doesn’t have IconSetData either and Blocs 2 is located in my Application Support file.
Any help would be appreciated. Thank you.


#18

Sure, this is what I have in that folder…


#19

Download this unzip it and replace your old icon directory with this one. You should be good to go then.


#20

Worked like a charm, thanks alot!