Will Blocs 2.4 work on mac OS high sierra?


#1

Will Blocs 2.4 work on mac OS high sierra?
thanks


#2

I personally haven’t tried it. I’ll install the beta in a few weeks and test it. High Sierra is more of a patch update IMO, the only major change is to how the file system works, which shouldn’t cause problems for Blocs.

There may be a few little tweaks required here and there but I can’t give you a definitive answer at the moment.


#3

Got it
Please when you have a moment give it a try and let us know
Thanks


#4

Using Beta Build 18 have not had any issues, so far.


#5

That news just made my week :slight_smile:


#6

Hi norm so i was stupid enough to download Mac OS high sierra and in the first version Blocs worked but then they released beta 2 update today and now its not working at all, i know you are super busy and trying to give us all the best version of blocs, but can you please look in to it as to what changed i mean eventually you will have to address it but I’m asking you if can look in to it for the next 2.4 beta 18 or 19 rather then later, please!!!

thank you


#7

What happens when you launch the app?


#8

Also I won’t be making any changes yet as it could be working in release 3. OS betas are renound for this type of thing, I could spend hours on something that will never be an actual problem in the public release. I’ll start testing the new OS in July, it ships in September so lots of time yet.


#9

Nothing it’s said it’s not compatible with the software and blocs doesn’t even open


#10

But yes I understand your point, it was just a bad call on my part, but thanks for the replay


#11

It sounds like an odd macOS issue.

Blocs is 64bit and compiled with the latest release of Xcode targeting the latest API’S so its defo up to speed.

Did you update your file system the first time you installed High Sierra? Maybe try re-downloading the beta as it could be a file system issue meaning you need a fresh install.

Keep me posted on any developments please :slight_smile:


#12

Yes you were right I went for broke and updated my laptop as well and blocs works fine on Mac OS High Sierra, so far the only issue is, reconnecting the files as it seems to lose some of them, but that was an easy fix.

Thanks again


#13

Cool, thanks for letting me know bud :slight_smile:


#14

As soon as the public beta of Mac OS 10.13 is available I’ll test it too.