Autoplay video on mobile

Yep,
you’re right.
Tested and confirmed.

1 Like

That’s good to know and I remember hearing something to this effect a while back. I still have to do some work on that video, but I’ve ticked the option now so I don’t forget. First I have to finish a client logo and then I have to complete my tax return online…

1 Like

Ouch, taxes. Grimm :face_vomiting:

I feel much the same way about the logo. Both are torturous.

Thanks heaven, logos never bothered me. :smile: Then every success to you. :+1:

This is really annoying. It was all working a couple days ago on mobile. Now I come back to it and it’s playing on desktop as expected but only showing a still frame on mobile and I cannot understand why. I tried swapping the video and it didn’t work, so I went back to the original video and that has the same issue now. This should just work as advertised.

Have you set a Poster (image) in the Blocs video settings? Do you use a class for the video?

No poster image is needed. It picks up the first frame of the video and uses that instead and there is no class on the video. I have also found that it is not working on tablet either, only on desktop. The issue seems to be autoplay, because it works as long as you have a play button.

I don’t think it is autoplay, because I have Autoplay switched on and Controls off. It didn’t work for me before but since I checked “Plays Inline” it plays now. Is it on Android mobile and/or iPhone?

Actually I just checked mine at the iPhone and the video does not work. It worked last week after checking Plays Inline. So the same is here.

I have enabled play inline and it does not play on Android, either with mobile or tablet. Just like you it worked last week, but not now.

Ok I just checked. Both my videos work fine on Android iOS with Firefox. The Problem is on iPhone with Safari.

What changed was, that I updated Safari after I uploaded on the 28.01.2020 my video setting corrections too the hosting server. I made some corrections to the tour dates today and uploaded the newer version and after reading your post it is that I discover that it does not work anymore.
I just tested it with the Blocs beta v.3.4.3 build 5 and no difference. So it is not Blocs.

I canot imagine what is wrong with it right now. I’m investigating further.

I restarted the iPhone and it shows the video playing! I

I have tried this now on various browsers and it is not working anywhere for me on mobile or tablet. I’ll try restarting the phone and see if that fixes anything, but this seems very hit & miss if that is part of it. The client told me it wasn’t working for him either.

I assume you have cleared the browser cache and history in all your browsers and then there is nothing left but to insert another bloc and a new video, adjust it and then upload to test it. I’m out of help now. :thinking:

Yes I have tried all that on various browsers without luck so I sent in a support tick to Norm, including the project file.

Yeah, I just tested this myself. I am having trouble too, it initially played, but now isn’t ?

In a nutshell that’s it.

Guys video auto play only works if you have the video muted. That is what is required now by the modern browsers even chrome on desktop, thats how the Blocs site auto plays videos, muted is enabled.

31

2 Likes

Is there any means of including a play button in instances where autoplay fails for any reason? I have seen full page hero blocs with video backgrounds that are completely blank on browsers like Brave.

I must say, that my video works also unmuted on iPhone SE with Safari, Firefox and Edge.video_unmuted

Try it:
https://sidneys-blues.de