Adding local web fonts in woff2 format makes Blocs crash


#1

Hello forum!

I was trying to add some local web fonts in the Blocs Font Manager.

fonts

First try, first crash!

OK, then I made separate folders for each font format and tried one format at a time.

.ttf worked
.woff worked, after I deleted the .ttf. Otherwise I was told that the font is already installed.
.svg brought up this error message
svg
.eot brought up the same error message
.woff2 made Blocs crash

Does this mean only .ttf and .woff are currently supported?
Or can there be another reason for this behaviour?

BTW, I am on Blocs 2.6.0


#2

I tried local fonts. No crash but woff2 is not imported.


#3

It may be the fact they include latin characters, have you tried any other fonts?


#4

You got the main release version?


#5

I use Blocs Version 2.6.0
I tried Open Sans and Lato
I thought latin (webfonts-helper) is the right choice …?


#6

@Norm

I got the font from webfonts-helper as well: https://google-webfonts-helper.herokuapp.com/fonts/merriweather?subsets=latin

Latin is the default.

I just tried to load latin-extented and Blocs crashed again.
Just for the fun of it, I tried cyrillic and Blocs crashed as well.


#7

I also tried renaming the fonts getting rid of the “-” character and making the name shorter but to no avail.