Blocs 2.5.2 + Pulse 5.1 b1

Btw what is the main issue you are having missing images?

Hi. Haven’t noticed the Support Link on the start-up screen. Apologies for that. I thought this forum was where Bloc users went for help and support. My fault entirely.

Briefly, yes missing images, but also the .htaccess file doesn’t seem to be appending the links either.

Look at to see what I get when I apply my site to Pulse CMS, and to see what the site should actually look like.

Me too…at least for simple things. I guess somethings are turning out to not be so simple.:slight_smile:

It’s fine, don’t worry. I’m just making it clear for anyone who reads this thread or gets frustrated with a forum posts lack of response. The forum is a place to get advice and help from the community. When that doesn’t work, go direct via in app support that goes directly to me and I’ll do my best to get it fixed up ASAP.

I think the images may also be somthing to do with htaccess. I’ll go through the thread over at pulse forum and get back to you early next week :+1:

1 Like

Thanks for the advice re: support vs the forum. Will follow those guidelines - if I ever need to - in the future.

If it’s of any assistance, Tim Plumb, who was helping me via my Pulse CMS forum thread on this issue wrote “Was this Blocs site ever set up for Pulse 4 by any chance? I can see the templates Blocs has output are in the older Pulse 4 format (that uses PHP to define the site path). When you exported the site did you export it using the Pulse 5 option?”

Obviously I confirmed to him that I had exported as a Pulse CMS 5 theme.

No rush to come back to me. I’m very appreciative of you taking the time to look at this for us. Thanks again.


Good news I’ve got this all fixed up. The fix will be included in tomorrows beta (build 6).

You should just need to export to Pulse 5 and images, videos will all load and page links will work again.


Smashing-dashing :+1:

Thanks @Norm for fixing this. It’s much appreciated.


No worries, I just wish I’d known a little earlier as I could have saved you some time.

1 Like

The Blocs Beta 2.6.0 – that @Norm launched this afternoon – is a lot better at exporting a Pulse CMS 5 theme. The page structure and links are all there, page swiper works and the blog module appears. However some of the images are still missing, specifically the images that have been added into the content of Brics. Images that have been placed in the background all seem to work.

I wonder if this could be because images from Blocs are put into the Pulse CMS / Template / img folder and I know that images that I’ve changed to the standard Pulse CMS default pages are stored in the Content / Media folder?

Something else that doesn’t work are links from secondary menus.


Are the images img tags loaded into pulse blocks? I’ll test for this it may still require work.

Also what are the urls for the missing images? Do they start with /template ???

I’ve double-checked and each img has been wrapped in a Pulse CMS tag. Is this correct?

Also I added a note about links from secondary menus not working to my previous note too. Sorry.

No. Links that are missing are and


Not sure if this screen-snap helps with the sub-menu links issue @Norm, but looking at the “Manage Navigation Links” panel in the Pulse CMS Admin dashboard, I can see that the secondary menu items created in Blocs don’t appear :thinking:

Regarding the navigation links. Did you hard code the page links with the URL interaction? Pages in a Pulse template don’t have the .html suffix. So you would need to set these URL’s to

Basically pulse cleans up the URL structure so you no longer need to include the page file suffix ie .html or .php.

Yes I did. But I now understand what’s happening. Thanks. I’m going to amend and export the site again.

1 Like

This works great now, but don’t add the full URL as @Norm suggested, otherwise Pulse CMS duplicates it i.e

The URL link for secondary menu items created in Blocs and destined for Pulse CMS should be /mypage#mysection



Ok so what problems remain? some missing images?

Yes some missing images and then I think we’re pretty much there.

FYI. I tried out Michael’s new locally with my theme exported from your Blocs Beta 2.6.0. It was a step backwards, missing links and missing images again. So I ditched it.

Strange, that’s what I tested with and it worked fine :exploding_head:

I’m not sure whether this will assist you isolating the image problem @norm, but looking at the code in the Pulse CMS dashboard I can see that the image links show the path to where the original files are located on my local machine, rather than where the file has been exported to.