Brain fade #2 - wrong page appears as 'home page'

My homepage is

But when just is typed into the browser this is the one that appears -

Any ideas how I can get round this?


@Ian Hi, If i understand you, you want the to show the home.html and not the index.htmi?
The browser always look for an index.html when going to an address.

There are ways to manually put redirect tag/code in the index.html so it instantly jumps to what ever you want.
But on the other side you won’t be able to see the index.html while that code is in it.

Probably better to put the test site in a sub folder instead.

Thanks - do you mean put the ‘incorrect’ home page ‘index.html’ in a folder?

I never asked Blocs to make a particular page the ‘home page’ - I’m guessing it just defaults to the first one created, whether it’s called ‘home’ or not, which isn’t overly clever!

Well that worked! The only downside is it’s faff having to upload two different sets of files to two different places.

But thanks, it worked.

I’ll ask Norm if he’s got any ideas - maybe it’s something for the next update!

The web page served when a directory is accessed is determined by the web server not blocsapp, or any other web development system.

I think the real problem is not so much in blocsapp but in trying to do something that is non-standard. Non-standard is fine, but you need to know that by default webservers will look for page names in a particular order, and index.html is what most webservers will serve the browser ( there are others, default.html, etc. ).

I may have missed it, but I don’t think Blocs documentation says anywhere that it’s crucial to make the home page first, otherwise it won’t actually be the home page, even if it’s called the home page!

There needs to be a way of editing page names in Page > Settings.

I’ve basically had to junk my home page as uploading to two folders is way too much hassle, especially when using super slow satellite internet.