Browser Preview Not working (older Blocs project opened in 4.3.2)

Older Blocs project won’t preview in the browser. Opened this older project (From May, 2020 - not sure which version of Blocs). Opened in 4.3.2. Using GOOGLE CHROME.

Here’s the message I get:

This localhost page can’t be found

No webpage was found for the web address: http://localhost:8080/index.(null)


Any help appreciated! - Randy

It’s a bit of a ‘vague’ post as not sure about your definition of “old” (Blocs 1?)
However, the (null) error is something I see randomly popping up with custom Brics.

1 Like

Are you using Monterey? I think that will require the latest version. Blocs has a new php solution to preview pages under Monterey.

1 Like

I’ve updated the original post with more info for you guys.

Using very new/recent version of Google Chome.

Which OS version are you using?

Version 94.0.4606.61 (Official Build) (x86_64)

Big Sur 11.4

Is there anything particular about the project such as using a CMS or custom coding? Does it preview inside Blocs?

Have you tried replacing (null) with .html

It’s configured as .html, so no idea why it’s displaying as .null ??

It does preview fine from within Blocs yes

Is the exported file correct i.e with html at the end?

There is a search feature for the forum which is really helpful. Also nice if you reply to people who try to help.


Thank you for that tip. Changing the page type to php, saving, then back to html and saving worked!

Now that it’s previewing, there’s another issue. There’s an odd margin to the left of the carousel when the page loads (on a desktop monitor). I’ve tried everything I can think of to address it, including using the inspector to try and locate the bug. Any ideas on how to resolve this one?

Here’s the website URL:

Not seeing that issue on my MBP 15’.

EDIT: Not seeing it on my M1 Mini with 27" screen as well.

1 Like

That’s odd… Thank you for testing. I’ve gone ahead and recreated the hero carousel and it works fine now. (haven’t uploaded changes to server yet).