Can't add fonts

I’m trying to add a font to my project. I have gone to font manager in Preferences, selected local web fonts and gone to the font folder in Library/Fonts to add fonts, but they are all greyed out.

What’s up? Why can’t I add a font?

Sounds like you are trying to add system fonts, whereas you should be adding folders containing web fonts stored elsewhere on your computer.

What @Flashman said.

Create a folder named fonts, preferably as a subfolder within your blocs project folder.

Download and prepare the fonts you want to use in blocs and put them in that folder - simply follow the instructions here.

I created a folder on iCloud called Web Fonts, so it is also available to other computers. Inside I place a folder for each font type with sub folders for each style variation e.g bold or italic. The files have been converted to web font formats.

In Blocs 4 you can now now bulk add multiple fonts, so I can select the main font type, which then includes all those sub folders. My only grumble is that I have to confirm OK for every font variation that is added. Given that the operation has already taken place I don’t see why we need to confirm it, much less do so multiple times. Once that has fixed it will be extremely fast and efficient adding large numbers of fonts.

Thanks folks. Got it working.

had to bump this, having the same issue, tried following the guides and everything is still greyed out Woff files, TTF files and EOT, even paid for a web specific version TTF and still greyed out