Experience with OLD Mac..... turning NEW one again

Hello, so today I decided if I sell my old MACBOOK 5,1, (13" Aluminium late 2008) or if I transform it in Windows PC, or if I try to install Catalina in it…

Well I decide to go to this last solution, and it works very well… (not official as Apple don’t have Catalina for this machine, it stops in El Capitan)… :stuck_out_tongue_winking_eye: :crazy_face:
So now I have my old MB with Catalina, and I have to say that it is faster then El Capitan that it have before.

Even my fans that before always work in max speed, now they are quiet, now I will install Blocs app and I let you know how it works…

This Corona makes me have some extra time to do things like this…

2 Likes

And Voila… I’m replying from MB, and there is a screenshot of Blocs and my MB:

That’s impressive and very encouraging that you can still do this with such an old laptop.

I recently prepared an old iMac 2007 for a trip to the recycling centre when they re-open because it would only run El Capitan and that is no longer compatible with Blocs, but there was no dosdude patch for my model.

My mid 2010 Mac Pro cannot officially go beyond Mojave, though some have done it. I was reluctant to try because I heard that something had to be disabled that could cause security issues. The plan is to try and keep going until the new Arm processors come out.

Yes for this one… all good…

:open_mouth: Oh wow! I’m trying that with my old 2011 mac mini right away!

Thanks for the tip Pealco!

Cheers,
Alberto

@Pealco, How in the world did you do that? I have nothing but issues with my MacBook Pro (2009). My OS X cannot go higher than El Capitan. You know that means I can only go as high as Blocs 3.2.1. :frowning: If you’re willing to share how you did that I would be so grateful! :smile:

2 Likes

I have got High Sierra on my MacBook Pro 5.5.
High_Sierra
I used the High Sierra patcher from dosdude. http://dosdude1.com/software.html
Obviously Apple does not want you to do this and you do it at your own risk.

I have been using it for about a year now and had no issues whatsoever.

I would love to get some feedback how Catalina is working on the old machines.

3 Likes

I have a clean install of Catalina on an entry level 2012 Mac mini and it is incredibly slow with lots of spinning ball just using the finder. This did not need any patch and is notably slower than it was on Mojave.

That one only has 4 gigs of ram, but I think the biggest problem is probably the old SATA drive, so it would likely run better with an SSD.

I forgot to mention my MacBook Pro has a SSD.

This is really cool! Thank you for sharing it. :smile:
I’m going to back up my old MacBook Pro and try it.

You can find some further reading material at https://forums.macrumors.com/threads/macos-high-sierra-10-13-unsupported-macs-thread.2048478/

Good afternoon, so I use a patch from this website:

http://dosdude1.com/catalina/

But you have to make sure you have the right equipment and is full compatible, if you go to About This Mac, and then you click in Sistema Report, you will see there a reference “Identificador de modelo: MacBook5,1” (Model Identification", and is this that you have to check…

But lets go step by step:

  1. Check if you model is compatible:
  • Early-2008 or newer Mac Pro, iMac, or MacBook Pro:

    • MacPro3,1
    • MacPro4,1
    • MacPro5,1
    • iMac8,1
    • iMac9,1
    • iMac10,x
    • iMac11,x (systems with AMD Radeon HD 5xxx and 6xxx series GPUs will be almost unusable when running Catalina.)
    • iMac12,x (systems with AMD Radeon HD 5xxx and 6xxx series GPUs will be almost unusable when running Catalina.)
    • MacBookPro4,1
    • MacBookPro5,x
    • MacBookPro6,x
    • MacBookPro7,x
    • MacBookPro8,x
  • Late-2008 or newer MacBook Air or Aluminum Unibody MacBook:

    • MacBookAir2,1
    • MacBookAir3,x
    • MacBookAir4,x
    • MacBook5,1
  • Early-2009 or newer Mac Mini or white MacBook:

    • Macmini3,1
    • Macmini4,1
    • Macmini5,x (systems with AMD Radeon HD 6xxx series GPUs will be almost unusable when running Catalina.)
    • MacBook5,2
    • MacBook6,1
    • MacBook7,1
  • Early-2008 or newer Xserve:

    • Xserve2,1
    • Xserve3,1

Machines that ARE NOT supported:

  • 2006-2007 Mac Pros, iMacs, MacBook Pros, and Mac Minis:
    • MacPro1,1
    • MacPro2,1
    • iMac4,1
    • iMac5,x
    • iMac6,1
    • iMac7,1
    • MacBookPro1,1
    • MacBookPro2,1
    • MacBookPro3,1
    • Macmini1,1
    • Macmini2,1

— The 2007 iMac 7,1 is compatible if the CPU is upgraded to a Penryn-based Core 2 Duo, such as a T9300.

  • 2006-2008 MacBooks:

    • MacBook1,1
    • MacBook2,1
    • MacBook3,1
    • MacBook4,1
  • 2008 MacBook Air (MacBookAir 1,1)

  1. Check your graphic card:
  • AMD/ATI Radeon HD 5xxx and 6xxx series graphics acceleration: Currently, it is not possible to achieve full graphics acceleration under Catalina on any machines that use a Radeon HD 5xxx or 6xxx series GPU. If you have a machine with one of these GPUs installed, I’d advise upgrading it if possible (can be done in 2010/2011 iMacs, iMac11,x-12,x), disabling the dedicated GPU if using a 2011 15" or 17" MacBook Pro (MacBookPro8,2/8,3, instructions to do so can be found here), or not installing Catalina. Running Catalina without full graphics acceleration will result in extremely poor system performance.
  • 2008 Mac Pro 3,1 AMD GPU Support: FIXED as of Catalina Patcher 1.2.0.
    • APFS BootROM Support: If you have a machine that supports High Sierra natively, you MUST ensure you have the latest version of the system’s BootROM installed. If you have NOT previously installed High Sierra, you can download and install this package to install the latest BootROM version. When installing, ensure your system is plugged in to power, or the update will not be installed.
  1. See this video: https://youtu.be/wxFzZWqoCng

  2. Check that you have to change your Hard drive system files to APFS before you choose drive to install. (You can see how in the video above)

  3. In the end you will have Catalina in your computer.

NOTE: It worked in my computer but no guarantee that will work in yours, and I will not be responsible if something wrong occur… :slight_smile:

If you have a system that is not compatible with Catalina, but is compatible with high Sierra you have here a different patch: http://dosdude1.com/highsierra/

Cant help in implementation has I not use this one…

Hope it helps someone …

3 Likes

I have High Sierra on a Mac mini 2010, SSD, 12GB Ram. It runs like that too HAHA.

I have toyed with the idea of using for a local server. But since everything is on the cloud it was kinda pointless. I would like to use it if I could.

@Pealco thanks for sharing that. I’ve tried while following complete instruct, as per the video, but I cannot get the choice in selecting my UBS drive when I hold the Option Key down.
I have a MacBook Pro (2009) v5.4. I tried disabling APFS and enabling, but neither one worked.
Any suggestions?

1 Like

For all of you who have spinning balls (sounds painful), and can change the drive for an SSD, you’ll be amazed at the speed increase.

This thread is amazing. I have an old iMac I might try this on.

Thanks for starting the thread.

[ Hmm - just remembered I have a hybrid drive somewhere that should speed up the existing drive quite a bit ( it has 4GB of SS RAM + HD ) ]

1 Like

I have a 2014 iMac with a fusion drive I was hoping to upgrade, but I keep getting the message “storage system verify or repair failed. :(-69716)” which is bloody annoying! Started up from my SuperDuper backup disc, ran Disk Utility and it couldn’t be fixed from there either.
So it looks like it’ll be a reformat of the hard drive and a reinstall from SuperDuper.
I hate computers.

You research is absolutely great Pealco!

1 Like

Hello @KBConcepts there is something that you have to do first, you have to format the USB before, the script delete content but don’t change format.

You have to go to disk utility and select the USB and erase and select this configuration:

Hope it helps…

@Pealco Just wondering how you are finding the performance on that computer with Blocs. A lot of these old computers have rather poor graphics capabilities and in many cases no dedicated graphics card at all, so they are under pressure at all levels.

Hello @TrevReav when I see your reply I remember that when I install Catalina in a friend computer I have exactly this error, and I record in my Quiver App two responses that solve my problem then, they were:

  1. How to fix a split Fusion Drive

If your Fusion Drive appears as two drives instead of one in the Finder, it’s no longer working as a Fusion Drive. Here’s how to fix it.

If you’re using macOS Mojave or later

  1. Turn on your Mac, then immediately press and hold Command-R to start up from macOS Recovery. Release the keys when you see the Apple logo or spinning globe.
  2. When you see the macOS Utilities window, choose Utilities > Terminal from the menu bar.
  3. Type diskutil resetFusion in the Terminal window, then press Return.
  4. Type Yes (with a capital Y ) when prompted, then press Return.
  5. When Terminal indicates that the operation was successful, quit Terminal to return to the macOS Utilities window.
  6. Choose Reinstall macOS, then follow the onscreen instructions to reinstall the Mac operating system. Your Mac restarts from your Fusion Drive when done.

I try this commands with the terminal that comes with the script and they work…

  1. https://support.apple.com/en-us/HT207584

Hope it helps you…