External javascript not loading (finally solved!)

SOLVED by disabling Lazy load AND Minify HTML…

Dear all…

Trying to get this script work:
<script type="text/javascript" src="https://www.marinetraffic.com/js/embed.js"></script>

I embedded it in the Code widget, when I do a preview it shows up in the browser, but when I preview in Solis it doesn’t show up, also not when I upload it to the site itself.

My gut feeling says I need somewhere a extra piece of code to force it to load, but so far my experiences in coding… Hope you can help me out with this one.

I am running 3.4.4. on Catalina 10.15.2

Question… are you running on a server with an SSL certificate, it might not like having a site without one.

Hi, thanks for your reply. The site does have an SSL certificate and is installed right. I tried my own site with this script (but that one is made with Rapidweaver) and is running fine. It is also weird that It seems ok when I do a local preview on Safari, but in Solis it is gone.

Yeah. I see on a search a few people seemed to have problems that appeared mostly unresolved. Did you try the extended code they also offer. Maybe worth trying.

https://www.marinetraffic.com/en/p/embed-map

I started with the extended code, then tried the “simple” code, different formats for the url, etc.

Hello @Barney, you just need to change https to http and it work, at least in mine works

You will see two as I put both https and http solution, but if you change in the url from http to https you will see only the https map…

Hope it helps you…

Hi, thanks for your suggestion, but I just got the solution from Norm…I already tried the HTTPS and everything, but it seems it conflicts with Lazy loading… So now I disabled that and it works fine.

1 Like

Oh thats interesting. Good to know, thanks for sharing the solution.

Well…The map show up now, but the first script (I am using the larger script with positions etc) is not loading ok. In the browser I see a “blocked a frame” warning.

You can see it at www.stinkybusiness.nl at the bottom

Comes up for me on iPad

Yes correct. But it needs to zoom in. It only uses one script of the 2

Like this (preview on local safari)

The script forces position, zoom in, different map and size

1 Like
<script type="text/javascript">
	width='100%';		// the width of the embedded map in pixels or percentage
	height='600';		// the height of the embedded map in pixels or percentage
	border='0';		// the width of the border around the map (zero means no border)
	shownames='true';	// to display ship names on the map (true or false)
	latitude='51.817954';	// the latitude of the center of the map, in decimal degrees
	longitude='5.425014';	// the longitude of the center of the map, in decimal degrees
	zoom='15';		// the zoom level of the map (values between 2 and 17)
	maptype='2';		// use 0 for Normal Map, 1 for Satellite, 2 for OpenStreetMap
	trackvessel='0';	// MMSI of a vessel (note: vessel will be displayed only if within range of the system) - overrides "zoom" option
	fleet='';		// the registered email address of a user-defined fleet (user's default fleet is used)
</script>
<script type="text/javascript" src="https://marinetraffic.com/js/embed.js"></script>

Hey @Barney

The error you get on your page is this…

If I am not mistaken, its to do with the settings of your server, same-origins policy. If you don’t have access to modifying yourself, you will need your hosting provider to amend the policy on your hosting.

@Pealco may know more about this?

1 Like

try change to http…

Not in the address on the safari but the address in the script.

I doubt that. If I upload the same script on my own website with Rapidweaver it works fine. And that one is on the same server

1 Like

I will try that ourt now

That is not working either…

Well the error is there. Interesting that a site made with RW works .