Finding lots of issues with 3.2.1


#1

Finding more issues as I go here… And I’ve even backed up to 3.0. @Norm? Are you aware of any odd issues affecting Blocs right now? Here’s some of the issues I’ve had this morning as I started working in 3.2.1, but then went back to 3.0 and still having more odd issues.

• top and bottom margin - visual adjustment - no longer works in 3.2.1. When I select and element then hold down the Shift key, the handles don’t show up. Or if they do, they’re behind the large ‘+’ icon which adds a bloc.

• suddenly there were gutters back where I had removed them. I had to go through a bunch of carousel photos and remove the gutters.

• Columns that were once centered were suddenly floating left. Even though my settings were still ‘auto’ for left and right margin.

• elements that were once hidden now remain visible. Even though I’ve still got them hidden in the settings. (see screenshots) This issue I can’t yet resolve. No matter what I try, they remain visible, even though the settings are apparently all correct. (I haven’t changed them and they worked perfectly before)

I’m still finding more issues as I go, but wanted to report these ASAP. I’ve been working on a large Blocs website for 2 months and am (was) hoping to launch this weekend, but now have to re-test the entire website and make changes. Worst part is, some features, I can’t get working (like the hidden state) at all.

ADDITIONAL NOTE: Now I see my screenshots appear fuzzy in the forum, even though they’re clear in my preview window to the right of where I’m typing here. I am guessing that coincidentally, there are problems with this forum as well. Come to think of it, I had problems logging in earlier too… I’ve attached an additional screenshot which shows what I’m seeing on my screen right now. (last screenshot)

@Norm, please advise.

Thanks, Randy


#2

First of all thanks for the heads up, ideally testing the betas help to avoid this, I’m not sure if you tried them?

The fill width settings are now more accurate as they only remove the padding from the left and right of the Bloc, this means if you want true edge to edge you also have to switch off the gutters on the inner row too. The old behaviour was actually technically wrong.

Regarding your launch, older versions of Blocs are all available here and you should always keep backups. So I see no reason why you cant revert back.

I’ll have 3.2.2 beta out on Monday so most outstanding items will be patched then. If you could send me a copy of the file that would be great.


#3

@Norm, thank you for the reply. No doubt you’re a busy guy today. I’ve already downloaded 3.1.2 which for me works fine. Thanks for the explanation on the full-width settings info. And by the way, I do save my project repeatedly throughout the day. I was able to open a version from late yesterday with 3.1.2 and it works fine. Just had to make a few changes to get it back to my latest version which got corrupted (or whatever you want to call it) when opening it with 3.2.1. So I’m back on track thankfully.

There’s one more issue that I’d like to bring to your attention. I’ve discussed it with Eldar as well.

I’ve had this very odd behavior with Blocs for as long as I can remember. I can’t be the only one who experiences it.

I have to often quit and relaunch Blocs to eliminate it. (not unusual to have to do this 10-20 times a day if I’m working in Blocs all day). Blocs often ‘grabs onto’ (and won’t let go) the most recently selected object I’ve worked with. It won’t let go until I click somewhere on a page to place it. It’s basically doing a ‘cut/paste’. I’ve even often seen it ‘paste’ an item I used on a different page. (And yet I know Blocs doesn’t yet support cut/paste).

I’ve tried clicking several different keyboard combinations (ie: Command+Escape, Option+Command+Escape, etc) to force it to ‘let go’ of whatever it’s holding on to but haven’t yet found a solution. I always know when it’s holding onto something because I suddenly see that ‘+’ icon following my cursor around and when I move my cursor around the page in Blocs, you can see the blue underline where it wants to place it.

Are you aware of this odd behavior? And if so, are you planning to fix it soon I hope? It’s not only annoying, but it’s also caused me a lot of problems where my Blocs project would change due to this and I didn’t catch it. Sometimes elements are gone from a page, but are present on a different page. It’s very troubling and time-consuming.

All that said, I still choose to work in Blocs. Overall I love it. I know you’re working on always making it better.


#4

Do you use a mouse or trackpad. Sounds like drag and drop is being triggered unintentionally.


#5

@Norm, I use a mouse. It’s wireless on an iMac if that makes a difference… Maybe I should try a different mouse??


#6

Yes, I have this too and yes, this is very annoying. As I told you Norman quite a while ago, that Blocs is influenced by the software and cursor movements of an application that lies visually over (like a layer on top of) the Blocs window.

If I have for example a Safari window, that is in the foreground and lays on top of the Blocs window, using the Browser Preview of Blocs with Safari and resize the browser window at certain times to see breakpoint behaviours and my cursor that holds the browser window edge of Safari moves over certain parts in the underlying Blocs area (e.g. the Brics or Bric selector) then the Blocs application reacts to the cursor movements. Blocs then thinks I want to insert a Bric. When I switch back to the Blocs application (= Blocs is in front now) the blue insertion line for a Bric is shown somewhere where within a bloc and when I don’t pay attention to this and click somewhere on a bloc area, I then insert unwillingly a brick.


#7

Hello @Creative

I am currently migrating a project from blocs2 to blocs3.2 and I am experiencing very similar problems.

In case of the hidden elements being displayed, I have found out (for my project) that this strange behaviour only applies to complete blocs. In other words, if let’s say an image or a paragraph inside a bloc was to be hidden, it works fine, but if a complete bloc was to be hidden it is suddenly displayed, not matter what settings you have for visibility.

My workaround is to create a new bloc in blocs 3.2, move the content into this newly created bloc and adjust the visibility. Then it works.


#8

Something very odd just happened with the image text bric.

It only aligns correctly at XS.

screenshot_1213


#9

@Flashman, you could try assigning a class to the image and entering ‘auto’ for left and right margin. That normally works for me. NOTE: Make sure to set the width of the bloc it’s in to 100%. (either in the class settings or here;

35%20AM

  • Randy

#10

It shouldn’t be necessary. In earlier versions of Blocs it centred automatically.


#11

Right. Let @Norm know. It seems there were a lot of things which got buggy in 3.2.1. I’ve already switched back to 3.1.2 as I’m happy with that version.


#12

That problem with the freehand margins not working is happening more and more. It’s now a regular occurrence. This has forced me back to 3.2.


#13

Norm told me he’s planning to release an update Monday. From now on, I’ll be smarter about testing new updates before opening actual project files.


#14

Im looking into this now.

Are you aware that the freehand margin controls no longer show when a text element is highlighted for text editing (second click on element).

Are you doing much text inputing?


#15

Any chance you could send em a copy of your project with the hidden areas that are showing in 3.2 so I can see what that is?


#16

Also have this problem. Like you, I’ve found the best solution is to mouse click the dynamic page background (any place on the dynamic page area outside a project bloc or bric) to force release of the last object being accessed. Recommend doing this when moving between objects and/or pages to prevent the unwanted transfer of objects. In cases where an object is accidentally transferred, use the “undo” command to remove the transferred object from its new, unwanted location and return it to its old location. If the object was removed from a different page, return to that page and use the “undo” command to restore the object to its original location. (I.e., the “undo” command appears to be local to the currently active page focus.) I use this as a temporary workaround until the issue is hopefully fixed.

Another temporary workaround I use a lot is for duplicated pages containing HTML Code Widgets which won’t save after being duplicated. In this case, after I duplicate the page, select the duplicated widget, make modifications if needed, duplicate the widget on the new page and, without changing the focus, delete the originally duplicated widget leaving the latest duplicate of the widget which can now be saved.


#17

This is not text editing. I simply click on a header or paragraph, press the shift key and no margin controls appear.

I went back to 3.2, but that created all sorts of issues. For example the order of items in the menu is reversed at mobile sizes. It also messed up all the header positions within hero blocs. Going back to 3.2.1 fixed nothing.

screenshot_1215


#18

What if you select an image? do they show then?


#19

At this precise moment it’s working for images and text, but I just can’t rely on it. Lots of random problems. For example, if I add a hero text left bloc the text automatically appears on the right.


#20

If I add punctuation like a full stop at the end of a consent label in a contact form it weirdly appears at the front of the text.