Form Issue - Mail server is not responding

Need some help here. I keep getting the following error message “mail server is not responding”. Godaddy can not assist. Godaddy needs to know what server is being used when emailing?

I am using the latest blocs software 5.1.4. I am using a regular gmail and yahoo email for To: and From:

Perhaps GoDaddy only sends emails through SMTP. Try adding your form that way, and everything should work fine. Test it out that way.

I’m having the same error using Gmail:

Try port 587, I think STARTTLS is hardcoded, 465 would require SMTPS in the conf file.
(And the password would have to be an app password, not your regular Google password.)

First I went for 587, with the same error, tried 465 to see if it make the difference… It doesn’t.

I think you want to use a “from email” from the same domain ideally.

Other wise, try the following (solution found online, but I haven’t tried it). As this more related to changes Google made last year.

There’s a bit of contradiction regarding 2-factor authentication as here it says it should be turned off:

When giving this a try I found another bug @norm :grin:

Blocs is stripping all spaces from my passwords :man_shrugging:

Small Potato 2023-11-20 at 10.34.06

1 Like

Interesting. :eyes:

Spaces in passwords are heavily debated too :grin:

We live in a grey world of opinions

I have never encountered any issues with it until now. :grin: From a security point of view it is brilliant.

It’s debated, that’s for sure. :policeman:

1 Like

Thats why I fool people with my password being backwards and upside-down :upside_down_face:

I am not Australian, so no one thinks down under :rofl:


If I am really being careful, I encrypt my text


1 Like

I have created Apps Password and used it in my Form setup - still the same error.

Can there be something wrong with PHPMailer?
I have tried multiple SMTP hosts - Active24, SMTP2GO, Microsoft365, all with the same behaviour.
Home (

Less Secure App Access is no longer available for Gmail accounts. (it’s available only for G-Suit users I think)