HELP! Text keeps turning white and won't go back!

It seems to be random, and doesn’t matter whether a class is assigned to the text or not… but it’s happening pretty frequently. I will have text on a page, and when I go to edit it in any way, the entire block of text turns white. No matter what I do, I can’t make it take on any color. I’ve tried assigning a custom class, changing directly… nothing works. I have to delete the text bric and start over… it’s the only way I’ve found to fix it, and it’s making blocs a pain to use. Does anyone know what is causing this? Is it something I’m doing wrong???

edit: it just did it again!!! I deleted the bad text bric, put in a new one, added the text, and it was fine. I then decided to add a custom class, and as soon as I click on the “Classes” area, the text went white… before I even typed anything.

LINK TO SCREEN VIDEO: https://youtu.be/bzmFSJK40-w

Hi @anapantz
did that also happen when you do a new project from scratch ? How you added the text ? Copy from a Texteditor ?
tom

I’m having the same problem and was just about to post this question.
I’m just using the trial at the moment and thought it was maybe a limitation of that, but obviously not!
Like Anapantz, I’ve added text either by copying and pasting from TextEdit (plain text), then either trying to change the font or colour and it jumps to ‘no colour set’. If I try to make it a colour, the colour shows in the inspector, but the text remains invisible.
I’ve checked that the colour isn’t set to 0%, so it’s not that. Nice to know someone else is having the problem and it’s not just me!
Thanks in advance for any answers or suggestions.

Hi @TrevReav
What text you use ? Heading or paragraph ? Goole Font or local Helvetica ?

Hi Tom2, it can be anything - it’s happened on both a heading and a paragraph, although on the heading it was slightly different, it went to a lighter version of the colour, something that looked like 75%, although the colour percentage was set to 100%.
The text was Montserrat in both cases, and on the para, I tried to change in to Josefin Sans and it disappeared. Tried adding new bricks and the same happens over again.
Thanks for the reply.

:thinking: I don’t understand that … What happened if you change the color in the settings? Click the left side the settings button (screenshot ) and than go to text and change for example the paragraph …

59

Yep, just looked there, and tried changing, and still the same problem. The rest of the paras, which were all showing, changed typefaces where applicable, but this replaced one, which I’d previously fiddled around with, remained invisible - I can select the copy, so I know it’s there.
However, deleting this para box and adding a new one in solved the problem (but if I then try to change the typeface or colour manually, it disappears again!)

I think I cannot help you but @norm ?
tom

No problem Tom, thanks very much for the input - I’m very new to Blocs, only been using it off and on for a couple of day and very much enjoying it - but I’ve learned just that little bit more from you by pointing me at the settings panel and playing with that, so very grateful for that.

Your welcome …I have learned a lot by watching the videos by @Eldar
great videos to learn. check it out:
https://eldargezalov.com/blocs-master
tom

Yes, I stumbled across them on Youtube when looking for alternatives to Adobe Muse, looked interesting, and that’s what sent me in this direction.
Cheers - Trev

Hi Tom. That is a great question. I originally tried using an older Blocs site and converting it, but was not able to duplicate pages, so this is a site from scratch. I have, however, been copying and pasting text from both the old site and TextEdit on my Mac, along with creating entirely new text. But I did not pay attention to whether this is happening with pasted text only. Now that you have brought this up, I will try to make note whether that is an issue or not. I’m thinking not, as it happens on headers as much as body text, and most of the headers I just type in rather than paste, but it’s worth checking into. THANK YOU!

SAME!!! I thought maybe it was something I was doing wrong. Maybe it its, but it is always good to know that you’re not alone. The help desk (Norm) is working on the problem, so hopefully we will have an answer soon.