Help with publishing, upload error


I have exported my website to desktop. I first uploaded to my cPanel in public-html, but I now get 404 not found error when I search online for my site. I tried again but now am getting “Your account may be over its quota or you attempted to upload a folder”. I dragged the entire folder into the upload the first time and it loaded 100%, but I still got 404 Not Found error on the net. I am not sure what to do next. I contacted help on my host site and they have escalated this as well. I don’t have an answer from them and can’t find an answer on your forum. I put in Google analytics, using my https:// and am using the https:// for my web address. Previous to that, I was just using www. without the http or https (on my previous website from several years ago). I am very new to this, so I don’t know what went wrong. I was guided by the host technical people to first upload it to public-html in my cPanel. I am on a Mac, and was told not to use Cyberduck, that I can upload directly to my cPanel area, but it isn’t working.

I appreciate any help you can give me, either to alter my web address, or how I can actually upload and publish my entire site and fix all these issues.

Thank you.

cPanel does not normally allow the upload of folders - it’s a file specific system. You can create the folders within cPanel and then upload individual files to those folders.

If you’re not using FTP, the best option is to publish your website to a folder on your computer. Select all the files and folders and zip the files into an archive (right click and compress). You can then upload the zip file to your your public.html folder through cPanel’s file manager and use the unzip facility in cPanel’s file manager to expand the zip file. This will place all your files and folders into the public.htm folder.

OK. Thanks. I will give that a try. Currently, I can’t upload anything to my cPanel, says my quota is full. The host site has escalated my ticket to the next level so I have to wait until they clear this so I can do it again. I will let you know when that happens and if this worked. I appreciate your answer.

Hello. I have reloaded a zipped file. It still does not show up on the web. The tech support checked and told me the following. I don’t know how to code, or how to check this or fix this. The files appear to be there after I export to my desktop, but somehow don’t show up once uploaded to cPanel.

Also, when exporting, I checked the following boxes: Minify HTML, Minify Main CSS, Clean Page URL’s

I don’t know if that was useful or should I have left them unchecked? In Eldar’s videos, those are all checked, and Enable Lazy Loading unchecked. I checked all the boxes.

See below the coding errors.

There are some code problems inside the index.html folder:

<link rel="stylesheet" type="text/css" href="./css/bootstrap.min.css?859">
<link rel="stylesheet" type="text/css" href="style.css?8397">
<link rel="stylesheet" type="text/css" href="./css/font-awesome.min.css">

These files should be loaded from /css/font-awesome.min.css but folder css is missing from the public_html. But font-awesome.min.css is listed in public_html directly. Please review the code and upload the proper directories or update the path to load the files from proper location.