How to share the Asset Manager - pb with Dropbox

Hello,

I am a new Blocs user and I have a problem with the use of the asset manager. I need your help ! :slight_smile:

We are developing our first Blocs project. The project is saved on Dropbox and we are two users (i.e. two computers) to share this project and develop it. The problem is the asset manager is visibly not shared. When an user puts a new file on the asset manager to include it in the project, the other user doesn’t see it.

Can we solve this problem ?

Thanks a lot for your help.

Are you linking to images in dropbox as though they were remote assets? I don’t think that would work. It’s probably an issue in this case, even with theoretically local assets, since you will each have different user paths.

Your best bet in an instance like this would be to remote host the images on a web server. Then as you update one project it should update the other as well.

In particular I use GoogleDrive where I save each project by folder (images, logo, mp3, psd etc) all the files I use in the current blocsapp project, this allows me to use the same project on two different computers without any problem, always when opening the project, it reads each active file without any failure.

things that I learned that in each computer the same typographies must be installed, the same bircs that are used, but with the files used in the project, there is no problem.

It’s just a save project, synchronize (in my case it’s a matter of seconds) and then use it on another computer if I require it this could be in (office and home). It works perfectly

I also had this same issue.

Then I realized that when you import an asses blocs saves a copy of the asset in
i.e.Macintosh HD\Users*username*\Library\Application Support\Blocs 3\tempAssetStorage\ExternalDrives\HD\RDI_SSD\3. WebCoding\Projects\blocsprojecti\ASSETES.

I found this by right clicking the asset and open folder.

That’s basically what I suggested earlier regarding different user paths. I think it’s perfectly possible to share project files via Dropbox, however assets will need to be stored elsewhere and the easiest option would be the server itself, since the web urls would remain constant.

Hello,
I’ve got the same issue but I can not found Blocs in Macintosh HD\Usersusername\Library\Application Support. I have to create it by myself?

Hello,
I’ve tried this option but blocs does not recognized the url. Have you got a specific way to do this?

Blocs should definitely be there. I would double check to make sure you are looking in the correct library.

Try going to Finder > Go > Library > Application Support > Blocs

I can not find Library

I have mine permanently switched on. Try pressing shift + command + L when you are inside the menu Aller.

screenshot_1268

I don’t know why but it does not work … I have no “Library”. I would like to try another solution : google drive - but I have also an issue with hyperlinks - it seems that Blocs does not recognize the hyperlink. Is there a specific process?

You must have a library or the operating system would not work. You are just having problems finding it. What version of Mac OS are you using? This may help http://osxdaily.com/2016/12/12/show-user-library-folder-macos-sierra/

Blocs does understand hyperlinks. It’s hard to understand your problem without seeing an example, but if you highlight a piece of text you will see the a blue pop up and you should click on the last option to create a link. This will place a blue border around your text.

screenshot_1276

Now go to the side panel and set the interaction as Navigate to URL and type in the destination.

screenshot_1277

If you were linking to an internal page you would choose Navigate to page and choose one of your pages instead.

NB If you just put the image assets on the server as I suggested a week ago you would be having far less difficulties here.

Hello @JulieLabbe1

FR:
Il faut cliquer sur la touche option pour que la Bibliothèque apparaisse.

EN:
You need to click on the option key to reveal the Library.

Option touche/key: OptionKey

MDS

Thanks, I’ve found the Library!
But when I’m in blocs and click on “add assets” then the library does not appear.
Grrrrrrrrr
I just want my colleagues to see the pictures. It is very frustrating.

Add them as remote hosted assets on the server and sidestep Dropbox completely. Problem solved. https://help.blocsapp.com/knowledge-base/asset-manager/#adding-assets

That’s exactly what I’ve tried to do but when I put the hyperlink in “URL” nothing happened.

That’s obviously an incorrect URL with spaces in the name and variables after the png file type. It needs to be something like https://example.com/images/house.jpg

This has to be on the server. Not Dropbox. Store the files in a folder on the server with a name like images, so that everything is clear and easy to manage.