Linked in url error

Dear developer

in the blocs app you provide option to add username for social sites which works perfectly fine for Facebook instagram etc

however for LinkedIn there are 2 formats

  1. in/ username which is for personal profile
  2. company/ username

blocs app by default add this url https://www.linkedin.com/in

which means I can only link the personal profile and not company profile

please remove the in from the linked url ASAP

as the company website is landing to different LinkedIn profile

thanks

You can easily change the links to whatever you want to, just open the “Follow Links” Bric in the Bric Builder, change things up in the html section, save your changes, and you’re good to go.

You only have to be careful when updating the “Follow Link” Bric, because then of course everything will be reset.

that’s one way to do it but imagine you have to manually update html every time you customise your website

I think it is stupid that app creator decided to have

https://www.linkedin.com/in

instead of

https: //www.linkedin.com

it is not an additional feature I am asking for just asking them to correct the stupid url of LinkedIn that someone decided to put there in blocsapp

the only reason I use blocsapp is to easily crate and update website

but if I have to manually update html every time

that’s waste of my time for someone else’s ignorance

don’t you agree?

I think you got me wrong, you only have to change the links once (you’ll save your changes to the “Follow Links” Brics!). As I said, you only have to repeat the whole process IF the “Follow Links” Brics gets an update in the future, otherwise your link-changes stay intact.

I don’t see the problem - I don’t see a bloc or bric that includes the linkedin option. Can you be more specific.

so in the social brick urls are predefined and you only add your social site username instead of whole url

for example Facebook.com/username

but for LinkedIn it is linked.com/in/username

and the problem is that linked I am trying to connect have /company/username instead of /in/ username

so when I add LinkedIn.com/in/company/username

it takes me to the wrong address

if I add the full url it is https://www.linkedin.com/in/https://www.linkedin.com/company/username

here I attached a picture it wasn’t like this before

thanks for taking the time @Ghost & @hendon52

Have you tried putting the username as in/company/username without the rest of the URL. I think blocs add the https:// LinkedIn bit automatically. It’s only the tail of the URL that is required in the blocs interface. I haven’t tried it because I don’t use social media, but got to be worth trying.

If this doesn’t work. It may be easier to add your own social media icons into a standard block and use the full URL to create the link.

Hi @Eldar

I am told that this is the blocs template issue

can you please confirm for me and how can I fix it

thank you

no because /in/company is not a proper url

linked can only land you to one either company or individual so I cannot have /in/company/username

already tried this

As I said before, here is a little more detailed step by step:
Got to the Blocs Menu > Developer > Bric Builder > Follow Links (in the left side bar) > open the Html tap > change the link > save.

1 Like

Then you should do what @Ghost suggested. Edit the bric and remove the in from the URL for LinkedIn. Save the change to the bric and add either an in/ or company/ in front of the username in the settings panel.

Hi,

Who told you that?

In any case, you can fix your problem by either editing the Follow Links bric like @Ghost suggested, or by rebuilding the icons manually using icon brics.

If you decide to try to second method, you can check my videos for Buttons in Mastering Blocs 3 course. I think you have my tutorials as well as templates.

Cheers,
Eldar

1 Like

Wow thanks @Ghost

didn’t knew this feature existed in blocsapp

it was really easy to do this way

you are a legend

have a good day :slight_smile:

1 Like