Menu items do not respond

I created a number of pages shown in the Primary Menu Bar. I can select these pages and they show up.
Some of these pages consists of hidden pages (not shown in the Primary Menu Bar). On these pages, the Primary Menu Bar is still visible, but none of the items are active.
I closed the project last night and it worked fine then. On opening again it does not…
How to solve this?

Greetz, Guus

Hello Guus,

Can you share a screenshot of your project? It’s difficult to say what’s wrong. Probably, you have disabled the visibility of your blocs.


dear @Eldar,

The 2 screenshots are 2 pages in the menu: ‘aot’ does not function, ‘mindfulness’ (and others do). If I click ‘aot’, it stays on ‘aot’. Then the others items are not approachable anymore.


this the other screenshot:

Ok, thanks for posting images! Can you open the menu manager, and open the settings for the ‘aot’ link?

Sorry for the delay. Not yet sure were to find the answers…
Here’s another screenshot of the settings of ‘aot’

… and the closed version of the menu manager

Hello again,

Thanks! Now I can see the problem. You have selected to exclude the aot page from export, meaning it only stays inside the Blocs app. Check the box, and everything should work fine again.

EDIT: Sorry, my bad. Looks like that’s not the problem.


Hello Eldar,

Still does not work. The settings of the other pages are the same by the way. I add the page ‘mindfulness’ which does function nicely

Yeah, sorry, I didn’t think through what I saw in your image!

Can you please PM me the project file or send the URL to the live draft, so I can take a look at it and tell you what’s the problem for sure?

PM? what is that?
And it is not life yet. Should I send the project, and how can I do that?

Personal Message. You can do that if you click on my name here in the forum.

Alternatively, you can send me the project file to gezalov at me dot com

Dear Eldar,

I just sent you a WeTranfer with the project named AOT-3.bloc to gezalov at me dot com

Could not figure out the PM unfortunately.

Yes, I got it.

I just tried to re-add the navigation bar from scratch, and it seams that everything is working fine. Not sure what was the problem with the old navigation, but it looks like it was corrupted in some way.

Let me know if the new navigation also works on your computer.


Dear Eldar,

I downloaded the project again, but unfortunately still with the same result!?

Can you tell me what you did, so I can try it here as well…

Dear Eldar
I tried the same now as you suggested and indeed it seem tot work now!
Costed me a few hours before I called for help, because as a novice, I doubted myself.
I think I did the same yesterday night and then it worked fine. When I continued this morning, the problem was there (again).
Thanks for your support! I’m grateful.


Great to hear it works!
Yeah, I am not sure how, but it seems that you somehow corrupt the file. If it happens again, I recommend to submit it as a bug report to the developers!


P.S. Next time you have a problem like this, do not hesitate to share it!

1 Like