My Blocs went missing on the Tree panel


#22

Hi Norm, I would be glad to try the Beta but I was put off by this text: “don’t use this version for mission critical projects.” How stable is the Beta?


#23

As long as you keep backups of your projects the beta tends to be fine.

The beta also runs along side the normal version of Blocs, so you don’t need to replace your entire workflow.

Just download it, open your project in this version see if its fixed and let me know, if you intend to work with the beta just work with backups of projects incase they become broke (which is very rare).


#24

OK, thanks for your help!


#25

Hi Norm,

I opened my Blocs file in the Beta Version as instructed. There are still 2 Blocs missing from the Layers navigator.


#26

Could you please send me the blocs project I’ll get it patched up.


#27

I’m using 3.1.2 and am having this problem. I have a navigation bloc that I’ve spent a lot of time on and there’s no way for me to see it in the tree. I want to be able to use the drop down button groups I’ve made but I’m unable to transfer them anywhere else now.


#28

Hi, I have had this problem with build 3, 4 and the current 5.

I think it would be good if there was a tool to do this repair automatically and thus not load @Norm of work.

it’s possible @Norm ??

thanks


#29

Afraid not, Im teaching the layer tree to understand the complex layouts that rich text elements like the paragraph can create, it gets messy fast when you are wrapping words in tags etc.

What you have to consider is if it doesn’t load on the layer tree you can always select it on the canvas, I appreciate its not ideal but the problem is not in the file, it is actually the layer tree getting confused and instead of crashing, it simply leaves out what it doesn’t understand.

What would be super helpful is if anyone who is using 3.2 beta and has missing areas, let me know and send me a copy of the file in question with a detailed explainintionm of were the missing sections are so I can patch it up.


#30

Try the beta of 3.2, it may fix the issues. Don’t remake your project, I can issue a patch if required.


#31

I’ve also had some problems with layer tree recently. I msg’d Norm yesterday with a specific problem I had between 3.1.2 and 3.2 beta versions. If possible, it would be nice to have some detect mechanism to let one know that tree had a problem. That way, user could undo problem operation(s) and retry in a different way.

Thanks in advance to Norm for his great ongoing support. :slight_smile:


#32

Yes, in the beta of 3.2 things worked for me.

I was able to access at least one of the navigation blocs in the layer tree and this allowed me to extract the drop down button groups I had built and put them into another structure that is working for me.

Thanks!


#33

It is currently what I am doing following the canvas, but I am worried about the situation produced in the tree for when I have to do the subsequent maintenance.

I will try to redo those full pages.

Thank you @Norm for your help, your great effort and your incredible work.


#34

I started my third Blocs project at the end of March with Blocs v3.2.2.

About a week ago I discovered that there were Blocs disappearing from the tree.

The first one was the header Bloc with a single logo, which I discovered would disappear and reaper when I turned navigation off and on, However it no longer reapers, though I do see the top bloc flicker when I toggle the navigation off and on.

The second Bloc was the content on the home page, which has pictures and text. I have not discovered what point created the issue, I might have to redo this page.


#35

Same thing happened to me. Several of my blocs are gone in the page tree panel. They still appear on the page, but are gone from the panel. HELP.


#36

Have you tried the latest beta release it includes more fixes for the tree?

Build 3 will be out later today with even more fixes.


#37

Ok but will it allow me to get my blocs back or are they gone FOREVER…? tear


#38

No forever, the layer tree is just very particular. Im working on making it more flexible pretty much every day./


#40

Layer tree not showing bloc. I am using 3.2.3.

@Norm do you want this project or is a fix in the works?

Rich


#41

ME TOO!


#42

I think Norm has fixed this in the new update v3.2.4
In v3.2.3 and v3.2.4b1 the tree vanished when i did a few specific steps, but not in the new v3.2.4 :+1: